Persistant and returning errors - reinstall from scratch?

This is like the fourth thread I am making at this forum. I keep having trouble with Viritualmin and I think I should reinstall the server from scratch. That the disk quota error came back again after it being fixed made me think that. The current problems I am facing are:

  • Impossible to make new viritual servers -> fixed once, now tried to fix it with the manner I used to fix it and it won’t work for some odd reason.
  • Upgrading breaks FTP… when I updated my Viritualmin and Linux it somehow breaks the FTP and I cannot figure out why, always have to revert back to a backup to make FTP work again.
  • Cannot change mail attachment size to over 8MB, even though it is changed in both Postfix and PHP.
  • The mail issue from last week makes me distrust the mail installation, prevent me from using it as a primary mail like I want to.

Especially the impossibility to update properly is critical. I am considering on making a new installation. The reason I open this thread is because I need advise on the Linux distro.

I have been running CentOS 6 64 bit. I am not an experienced Linux user, but I can save myself in the command line ;). Maybe this is all caused by Cent OS 64 bit. Should I move to Cent OS 32 bit instead? Or should I try Debian or Ubuntu to see if it all runs better than this? Because I am finding it difficult to live with these silly errors the whole time. This ofcourse is not needed when a fix can be made for the problems I have, but I think it is all in vain as the quota error has returned in like two weeks.

My websites still run great, but as I already said I really need to be able to update without trouble.

I’m afraid without further detailed information we’re unable to provide any help here.

What errors do you get when trying to make new virtual servers? How did you fix it and what happens now?

What does “breaks FTP” mean? What did you update and what EXACTLY happened?

Where are you trying to change attachment size, and where does it make problems?

What “mail issue from last week” are you talking about?

I don’t think this is a Centos problem. I agree with Locutus, more information would be needed to help.

But maybe you activated additional repos on your system? This is known to cause problems.


Apologies, I wrote this when I was a bit pissed off when the quota system stopped working again and I couldn’t fix it ;). This is already my fourth or even fifth thread here so I was thinking about a reinstall because something might be messed up on my system. I do have an extra repo, the one needed to get FFMPEG working.

With the quota error, I tried fixing it on the way I did before in this thread: and it didnt work when I wrote this thread. Now I retried it and it is working again for now. But I find it very strange that it just randomly ‘broke’ again.

With the mail issue I mean this thread: this made me distrust my mail however since I feel it randomly may go down again ;).

These issues remain right now: Doing any update of viritualmin somehow breaks the FTP. I cannot login anymore, with any account. I always have to revert to a backup, then everything works again. But I really need to be able to update ofcourse. I have absolutely no idea what makes it break, and I found myself unable to find the log files as well as reinstalling the FTP server as when I tried that I broke down the rest of Viritualmin as well, lol.

The mail attachment size. I once bumped it up to 8MB somehow, but I cant get it further. I have both maximum size of a mail at 100mb, and PHP max upload size at 100mb. Is there something I am missing?

Thank you again for even considering to take a look at my thread. I really wish I can afford to pay Pro as I think you guys deserve this. You made it possible for me to run my personal website, my father’s bussiness website, my gaming website, my own mail account with my name as domainname and a big online backup all in one, in a very easy to use package. It is just a shame that there is something wrong with my server configuration which is causing these errors, and I don’t know what.

These issues remain right now: Doing any update of viritualmin somehow breaks the FTP. I cannot login anymore, with any account. I always have to revert to a backup, then everything works again

I’ve seen that issue occur when pulling in ProFTPd from a third party repository.

What repositories do you have enabled?

You can determine that by running this command:

ls /etc/yum.repos.d/