Permission Issues on Directory

Hi all,
On my fresh Installation of Virtualmin on VPS i am facing this Problem. After creating a Domain i moved my htlm Installation (Wordpress and Joomla) with ftp on /home/public_htlml

I could move the files successfully and both webites are runing -now. But there is persmission issue on the directory cuz i am not able to update or install any plugin on both CMS.

What i checked.

  • CHOWN und CHGRP are sofar Ok (domain1:domain1 , domain2:domain2. ( also change with command-line with ssh login)

  • i aditionaly validate both server with the option “Limits and Validation”

  • i aditionaly verify the optioni “fix permissions” under the option “Limits and Validation” after FTP Transfer

  • I Changed under “Server Configuration -->Website Options” the PHP script execution mode by setting mod_php and FCGId

Now the problem till not solved. :frowning:

For the test, i created a new CMS (Wordpress) over the function “Install Scripts”. But the problem ist here the same.

Could somebody give me any hints.
Thanks alot… :slight_smile:

who is the owner of the public_html directory on the virtual server where wordpress is installed?

On mine it is always the virtual server name (whatever you called the new virtual server you created in virtualmin)
also, all files and folders in this directory are owned by the virtual server name too.

so if i created a new virtual server and called in Adam, then the permissions on mine have Adam:Adam (owner:group)

quite often, people log into virtualmin via as root. If you do this, and then create new virtual servers, and especially if you then upload files to any of these virtual servers using the root login, virtualmin will automatically assign root:root (owner:group).

This will cause problems in that wordpress wont have the correct ownership and permissions to update.

You do not need to chown,chgroup btw. Go into virtualmin file manager, select one of the files in the directory and check its permissions from there.

if that isnt the problem, then i think you probably have an issues with the way you have configured your apahe/nginx webserver user or the way in which webmin is setting up new virtual server users when it was first installed. Someone else will have to help you with that one.

@adamjedgar: Thanks for your hint.
I created the Domains with the way as you desribed on your first lines. So public_html has the same rights as the virtualserver created and not as root or some other username.
Now if i make this mistake, i have possibility to fix the permissions. so everything seems to be right by permissions on virtualserver.

I will try now to check apache Webserver. Any idea where to check it ?