Permission denied

HI all,

I have multiple virtual servers and I am getting this error in all of them

Permission denied: /path/to/web/data/html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

This is a fresh install on Ubuntu 10.4

Any advice ??

Thanks in advance.


it seems that you have to make the .htaccess file readable…

Thank Ronald. I was trying to make .htaccess readable then I came across this article on the internet.

It seems that it is permission problems on the folders and not on the .htaccces file

Anyone with the same issue: Here is what I did

#chmod 755 /home/domain

#chmod -R 755 /home/domain/public_folder

It works now. Been having this issue for a long time now, I even reinstalled the OS and started fresh.

great that you’ve found it. strange though as folders should be 755 under the public_html
You can check this in your template configuration - Apache website - Permissions on website subdirectory 0755

This is a bug report.

I installed Virtualmin GPL on Debian 6 x64 and made 2 virtual servers with it.

Problems booting the server - websites always come up “Permission denied.”

Workaround, had to issue a service apache restart command , to get the websites to work. Very bad.

Thanks to this thread, I found part of the cause of the problem.

Cause. The value in Virtualmin / System settings / Server templates - Apache website - Permissions on website subdirectory, is wrong. It’s 750 by default.

Partial Solution, I had to manually change the skeleton setting to 755.
Click save.
Then, I had to manually fix the permissions on the existing 2 servers sites’ home folders.
chmod 755 /home/site1
chmod 755 /home/site2

And the site is still giving the 500 error just after rebooting !

Any suggestions ???