Perl-IO-Tty not compatible with Perl 5.16

Hi masters,

I’m running Virtualmin on a custom Red Hat distro (Amazon AMI) and it worked fine until now.

I noticed that we have some updates for Perl, upgrading from version 5.10 to 5.16, but a single Perl package called “perl-IO-Tty-1.08-3.el6.i686” is not compatible with Perl 5.16.

I only can upgrade it if I remove perl-IO-Tty, but doing this it removes virtualmin-base too.

Please, how can I get a package of perl-IO-Tty compatible with Perl 5.16 to install back webmin-base?

Thanks a lot and regards


Having the same issue on my Amazon AMI based EC2 instance. Everything was OK except for these last round of updates needed on the server.

Error: Package: perl-IO-Tty-1.08-3.el6.i686 (@virtualmin)
Requires: perl(:MODULE_COMPAT_5.10.1)
Removing: 4:perl-5.10.1-136.21.amzn1.i686 (@amzn-updates)
Updated By: 4:perl-5.16.3-280.36.amzn1.i686 (amzn-updates)
You could try using --skip-broken to work around the problem

Any way to resolve this incompatibility?


This problem was fixed with the following suggestion from AWS support:

To get around perl-IO-Tty-1.10 not being available you can do the following:
sudo yum install perl-IO-Tty-1.10 --disablerepo virtualmin

I had one problem with this, in that my Webmin wasn’t working after the upgrade. I had to reinstall the Webmin RPM and after that everything looks good.

Your mileage may vary. As always, do take a backup of your system prior to attempting any changes. Hope this helps someone.