Passive FTP not working, even with firewall off

Hello all.

I’m trying to make ProFTPD Server work in passive mode.
I’ve read several FTP posts, and did tried everythind I could find, no success.

My last test was to disable the firewall “service iptables stop”. It still doesn’t work!

I don’t have any other firewall/nat active.

What do I have to double check on ProFTPD configuration? Where else can I look?

Thank you

Rogerio

Howdy,

What problem are you seeing exactly? What are the symptoms, and any errors you receive?

Are there any messages in the logs? Depending on your distro, you may want to look in /var/log/messages, and /var/log/auth.log or /var/log/secure for some clues.

-Eric

Hi Eric,

The problem is I can login, but it fails the LIST command.

I’ve found some errors on /var/log/secure

Aug 31 12:19:57 linux02 proftpd[13977]: linux02.intercode.com.br (::ffff:189.102.217.172[::ffff:189.102.217.172]) - USER cushwebmaster: Login successful.
Aug 31 15:19:57 linux02 proftpd[13977]: linux02.intercode.com.br (::ffff:189.102.217.172[::ffff:189.102.217.172]) - Preparing to chroot to directory ‘/home/cushwebmaster’
Aug 31 15:19:57 linux02 proftpd[13977]: linux02.intercode.com.br (::ffff:189.102.217.172[::ffff:189.102.217.172]) - mod_delay/0.5: delaying for 52118 usecs
Aug 31 15:19:57 linux02 proftpd[13977]: linux02.intercode.com.br (::ffff:189.102.217.172[::ffff:189.102.217.172]) - error setting IPV6_V6ONLY: Protocol not available

What’s next?

Thanks a lot

Rogerio