Page downloads instead of loading

Guys, It seems that one thing gets fixed and then something else surprises you. I installed several versions of PHP onto server, and now all pages download instead of loading. I tried setting the default PHP version and still have the same issue. Some pages download and some I get error 500. Would anyone have any suggestions, please?. I’m using Ubuntu 20.04. Thanks

|—|—|
|||
|OS type and version:|Ubuntu 20.04|
|Webmin version:|REQUIRED|
|Virtualmin version:|REQUIRED|
|Related products version:|RECOMMENDED|

Never mind. Fixed.

You can help others by saying briefly how you fixed it. (I’ll guess you installed mod_php, but there are others ways this can happen, too.)

O.K. After setting default PHP, I restarted Apache and cleared cache. I noticed the cache issue when I tried loading site incognito. I also realized that you can set each server with a default PHP. At first I was under the impression that the setting would be server wide.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.