Outgoing mail server setting (in Outlook), defaults to domain.com, rather than mail.domain.com

Hi guys,

When setting up the email address in Outlook, autoconfig/autodiscover works perfectly, finds all the relenant information, but:

  • Incoming mail server: mail.domain.com (correct)
  • Outgoing mail server:domain.com (not correct)

The outgoing mail server gets populated as domain.com, instead of mail.domain.com.

Where in config in VirtualMin can I rectifiy this, so the correct information gets pulled through in Outlook.

Also, sending of emails don’t work: I need to go into More Settings\Advanced (in Outlook when setting up the email) and change the encrypted connection to TLS (it defaults to ‘None’). The port 25 and 587 both work. If I dont make it ‘TLS’ it does not send emails. Is there a way to default to the correct information in Outlook. Less of burden to my clients setting up their emails…

Please advice.



You can tweak many of those settings in System Settings -> Server Templates -> Default -> Mail Client Autoconfig.

There, you can set the exact hostnames to use, as well as whether SSL is enabled.

Let us know if that does what you’re after!


Thanks, I investigated those settings, and left it untouched. I then removed (set it to ‘no’) the autoconfiguration for client settings (so DNS Zone dont have these entries as well), and it pulls through perfectly now. Does not make sense, but its working now. I need to read up more about autoconfiguration…

andreychek thx for our assistance