Other DKIM issues


I started having problems similar to this thread where my emails weren’t signed even though my DKIM looked good: https://www.virtualmin.com/node/52896

In my own efforts to fix it, I tried deleting my DKIM records and recreating using the Virtualmin “DomainKeys Identified Mail” section under the “Email Settings” for the virtual server.

When I try to save my settings, I get the error:
Failed to save DKIM settings : Missing or invalid selector - must be a valid DNS record name

I look at the page and there is no box to enter a selector next to the line that says “Selector for DKIM record name” (between “Signing of outgoing mail enabled?” and “Reject incoming email with invalid DKIM signature?”). I do see a box for “Size of new DKIM key” and every other entry under that.

So it seems there’s no way to enter it, but no way to generate using this page without entering it… I tried several browsers to make sure it wasn’t just some weird browser display issue (Firefox, Chrome, and shudder even Edge).

Anything else I can look at here? Should I only be generating these manually? It worked perfectly for me in previous versions.


Here’s a photo of the issue for clarity: https://i.imgur.com/130lIvx.png

Hi, if you encountered this after a recent Debian update it’s because Debian overwrote your DKIM config file. Open /etc/opendkin.conf.dpkg-old and copy the Domain Keyfile and Selector lines. Paste those below the commented similair lines in the real opendkim.conf. If they exist delete the lies after UserID at the bottom of the file. Restart opendkim then run the Domainkeys Identified Mail setup under System Settings. DKIM should work now.

Thanks, seanieb64! That was exactly the issue.

I was also having issues with emails not being signed in general, but that looks like a similar configuration file issue (Socket was configured incorrectly).

Now to figure out why my emails are still considered spam :confused: But that’s separate