Oh Oh! Where'd the server templates go?

I upgraded to the 3.20 and my server templates disappeared. When I click on a template name all I get is:

plan1

Edit template section: Basic settings and usageVirtual server creationPlugin optionsDefault script installers

(a drop down menu)

Virtual server template details (Basic settings and usage)
(a title)

Template name
(a text box)

For use by Top-level virtual servers , Sub-servers , Alias servers , Server owners

(Check boxes)

I get the same for creating a new template, all the definitions are gone.

existing servers are okay but I can’t build a server through the API, though I think it’s building correctly when done manually.

I forgot to add, that there is nothing editable in the templates now

Hey Dan,

This is a new feature of Server Templates in version 3.20 (requested by several users)–the dropdown menu provides access to each of the various types of configuration you can do in Server Templates. It’s intended to make Server Templates a little less intimidating. Though I can see how it might be a bit disorienting at first glance if you expect to see all of the options laid out on one page as it used to be.

The API thing sounds like an actual bug, however. You should add the error that you’re getting to the bug you’ve opened about this issue (or open a new bug), so Jamie can address it.

Hi Joe,

The drop down menus are fine, it’s the fact that the menus don’t display. ie, there are no options to change or add. What I get I typed in verbatim, sans the HTML table.

I haven’t touched anything so the menus should be okay, where ever and what ever they are.