Odd... lost connection installing backups, now refuses connections

So, I set up a new server, ubunto 18.04, on linode.com, installed Virtualmin GPL, no problems, backed up my domains on the old server, saved them to the new server, uploaded 4 of them, no trouble (had not switched over dns or anything yet, was just restoring them one at a time before I started checking on them).

During the restoration of the 5th domain, the restore stopped. I got a message saying the connection was lost.

Tried refreshing, also tried going to the Virtualmin dashboard, but all I get is “connection refused”.

I can use the console on linode.com to access the server, but if I ssh in from my laptop the connection is also refused.

Did I somehow trigger fail2ban or something? What can I do about it?

Thanks,

Chris

Hi,

What is the output of:

systemctl status sshd

…and

systemctl status webmin

Oh, sshd is active and listening.

Webmin says:

Tried stopping/starting webmin, then ran journalctl -xe as it suggested, got:

I do see some references online to LSB failing to start related to ssl issues and Lets Encrypt, but I don’t use Lets Encrypt. I do have https enabled in the config for each domain, but use cloudflare ‘full’ for the rest of the https.

Ok, thought maybe this was related to 18.04, so I spun up an Ubunto 16.04 lts and repeated the same steps as before.

Got to the same site that caused a problem last time and had the same thing happen. Grabbed a screenshot. Looks like the mysql install goes bad, and things rapidly deteriorate from there…

that last line after ‘re-starting usermin’ is ‘done’, but the connection was lost and I can’t get it back up.

I’ll trash this server and try again without that particular site. Other suggestions or potential reasons for this?

Chris

No, darn, happened again when uploading a different site. Earlier in the process this time.

I’m moving the sites from a centos 7 install to ubunto, I wonder if that is causing the problem?

To try and get yourself going you can try the migrate process which is done from the command line. I’ve used this a couple of times without issue.

https://www.virtualmin.com/documentation/system/migrate

Regarding your problem, just throwing this out there but is there a problem with the backup itself? ie. Are all the permissions correct, databases owned by the virtual server, and so on prior to making the backup?

1 Like

Thanks Noisemarine, I will look into that.

I did start up another Centos 7 linode and was able to transfer them to that successfully. It seems like it was that they wouldn’t load unto the Ubunto for some reason. Would doing it by command line have made a difference?

No idea really, but it does seem to be the recommended method to move servers.

Ok, will read up on that, thanks :slight_smile:

This looks like memory issues. Try adding a swap file or adding more RAM to the instance.

1 Like