NS RECORDS set up my domain with no errors ns records show no errors and bind shows no errors

Hi ive just installed virtualmin on ubuntu 18.04 set up my domain with no errors ns records show no errors and bind shows no errors. im new to virtualmin. i can send mail from within usermin but not able to receive emails. error mailbox unreachable

Any help in pointing me to the problem would be greatly appreciated, i have been looking for days but cant recognize the problem.

many Thanks in advance

Just to verify

Beginning validation of selected virtual servers. Any problems found will be shown in red …

mydomain.com

All features OK

Hi,

Have a look at our basic guides:

DNS Resolution for Mail:

https://www.virtualmin.com/documentation/email/troubleshooting

How do I setup nameservers for my server?

https://www.virtualmin.com/documentation/dns/faq

host -t mx mydomain.com

mydomain.com mail is handled by 10 mx00.---------

after using “host mail.mydomain.com” this is the response,

host mail.mydomain.com not found : 3(NXDOMAIN)

host (ip address) resolves all ok

After using DIG

dig web-prob.mydomain.com

; <<>> DiG 9.11.3-1ubuntu1.11-Ubuntu <<>> web-prob.mydomain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 32621
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;web-prob.mydomain.com. IN A

;; Query time: 7 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Thu May 07 14:32:47 CEST 2020
;; MSG SIZE rcvd: 54

<<>> DiG 9.11.3-1ubuntu1.11-Ubuntu <<>> cass7.mydomain.com
global options: +cmd
Got answer:
->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 49
flags: qr rd ra QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

OPT PSEUDOSECTION:
EDNS: version: 0, flags: udp: 65494
QUESTION SECTION:
cass7.mydomain.com. IN A

Query time: 7 msec
SERVER: 127.0.0.53#53(127.0.0.53)
WHEN: Thu May 07 15:12:41 CEST 2020
MSG SIZE rcvd: 51

can you point me in the right direction hopefully this might solve the problem

many thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.