Not receiving emails


Im a newbie who loves messing and decided Im going to try and get my rasberry pi to be a home email server now to my amazement it nearly works the only problem I have is I cant receive email to the accounts I have created but it sends fine. I have googled the errors and tried everything I have dound in forums etc but nothing seems to work the error message I get is

<> (expanded from <>): Command died with status
2: “/usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME”. Command output:
sh: 1: /usr/bin/procmail-wrapper: Exec format error

Any help would be appreciated

Thanks Paul

OS type and version Ubuntu Linux 20.04.4
Virtualmin version 6.17-3

ARM is not a supported architecture for Virtualmin, because there is no procmail-wrapper binary for ARM in our repos (and also because it is untested and we don’t have any Pis or other ARM machines for testing).

You will need to build procmail-wrapper yourself, or not use the mail processing tools in Virtualmin. Install it suid root, if you’ll be building it.

1 Like

Thank you for reply :slight_smile:

Yikes, any tips on doing this please Im just starting to learn so could do with a couple of pointers


I’ve set up another machine and now it works but now I got more problems for another thread :see_no_evil:

Than you for trying to help

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.