No virtual host found for and also No virtual host found for

I used server replication to move all domains from one server to another one, then I switched IP addresses on the servers, and all the sites on the new server started to work OK. I thought all was OK.

I went to install a CA Certificate for a SSL I am setting up (its a multi domain SSL) and I got this:

Failed to save CA certificate : No virtual host found for

I thought it may be a SSL issue, but then for another server I got this when editing Website Options:

Website options cannot be edited, as no Apache virtual host for port 80 was found!

If I go to Webmin -> Servers -> Apache, in the Existing Virtual Hosts list it only lists a few of my servers here (and Website Options works OK for these), whereas my other Virtualmin servers usually show all servers here. I can see the virtual servers are defined in httpd.conf. It seems the servers missing in this list would show the above errors.

So is there an issue with the virtual server setup, so the system thinks there is no virtual host for the site? But there must be a virtual host setup OK as all sites work fine.


Oh no, I did a Virtuamin Re-Check Configuration, and I got this:

Apache configuration errors were found :

httpd.worker: Syntax error on line 1275 of /etc/httpd/conf/httpd.conf: Expected but saw

I had this yesterday (see after I first moved all sites using Replication, but I thought I checked it the second time. This means if I restart Apache it wont start due to this httpd.conf being messed up, and all my sites will go down. I am not sure how to fix this.

Fixing the other issue I reported here, has fixed the “Website options cannot be edited” issue, BUT I am still getting the issue “Failed to save CA certificate : No virtual host found for

I disabled SSL on the virtual server, then re-enabled, and now CA Certificate works OK.

I guess there is an issue with Replication somewhere, to mess up the httpd.conf like that

Good you found a solution then please tell what you did so other can gain from it instead of just ask and require answers when you don’t give a f… of others