No restore possible from successful backups

hello @all,

what am I doing wrong?
Today I wanted to restore from the configured scheduled backups.
(Virtualmin 3.81Pro on Debian 5 Linux 2.6.26-2-amd64 on x86_64)
Every night it runs a full backup of all virtual servers(88) with 3GB and I get a “completed…”-email.

Backup configuration:

  • Servers to save --> All virtual servers
  • Features to backup --> Backup all features
  • Destination --> FTP server
    – Transfer each virtual server after it is backed up
    – Halt the backup immediately
    – Full (all files)

Restore configuration:

  • Source and format --> FTP server
  • Features and settings --> Restore all features
  • Other restore options --> default…

…Show What Will Be Restored:
All servers available with this note below:
“No selected features in backup”
…and this at the end of the listing:
“None of the selected features are used by any of the servers in this backup, and thus the restore cannot proceed.”
…and no button.

It seems I have not really one backup…:-(((
Does anyone have an idea?

Thanks for help!

Can you check out the backup files on the FTP server, what their directory structure is and what they contain exactly?

I have 7 directories, one for each weekday like:

  • hostname_monday
  • hostname_thuesday
    and so on.
    in each directory there is this combination for each virtual server:
    -rw-r–r-- 1 u15283 u15283 252533488 Oct 26 10:00
    -rw-r–r-- 1 u15283 u15283 252 Oct 26 10:00

If I choose exactly one virtual server(/hostname_thuesday/, I can restore him but there is no way to restore all at the same time.
I also tried the other methods, like one file for all servers and so on but with the same result.

Which directory did you specify as restore source, when you tried to restore all servers at once?

My assumption at this time is is that the restore function might not recursively look into subdirectories of the restore source, thus won’t find your backup files which are located two levels below the source, is that correct?

You might try renaming the backup files in the subdirectories to and so on, and then use the directory where you place the files as restore source.

“Which directory did you specify as restore source, when you tried to restore all servers at once?”


“…thus won’t find your backup files which are located two levels below the source, is that correct?”

No, not correct.
All tar-files of monday are stored in: /hostname_monday/
There are only 7 directories on the ftp server with the tar-files directly in it.

However, I will make some tests tomorrow.
At the end I restore server by server…
Thank you for today!

Okidoki, I wish you good luck with that!

Just in case: Generally, restoring muitiple backups at once should work, I already tested that with several TGZ files in one directory.

I wasn’t using FTP then though, but a CIFS share mounted locally in the file system tree as “/backup”. If you have a chance to test that… might be worth a try. As in: copy the backups to the local file system first, maybe the FTP option has a problem.

Hi Locutus,
now I know the reason…
My provider is using a new backupserver with more supported protocols and upgrading features for future needs.
I took a look in the archives of the old backupserver and there are only 88 tar.gz files of 88 domains.
As I wrote at the beginning, on the new backupserver there are additionally 88 files. It seems that the backupserver writes an info file after each successful transfer of a tar.gz.
If I delete these info files, everything is fine and also the restore works properly.
Ok, not a problem of a virtualmin module:-)
I wait for an answer of my provider how to prevent the creation of these info files…

Thank you for your answers and help!


Okidoki, you’re welcome, and glad you found that out and pointed out a potential undesired side-effect. :slight_smile:

Well, for one, the hoster should not create odd “info” files after transfers. Might be a misconfiguration of their FTP server. Maybe you can use CIFS instead.

Also, it might be a good thing if Virtualmin skipped non-backup-archive files in the restore source folder, if that is doable?