No Post-Install Wizard

Hi, have just done a minimal install of virtualmin with both CentOS and Debian on an vps.

There doesn’t appear to be a post-install wizard that runs on first login as documented in

There is a ‘Re-check and refresh configuration’ button which wants to be pressed, but I seem to recollect a yellow bar across the top of the UI indicating that the wizard was running in previous installs. Has this changed or (more likely) am I doing something wrong?

many thanks



Hmm, this is an odd one. A few other folks mentioned that they experienced this recently, though we haven’t been able to reproduce it yet.

Does it work to go into System Settings -> Re-Run Install Wizard, and run it from there?


Hi again Eric, if you wish, i have no problem in giving you access to my server. Currently it has installed a clean version of debian 8.6 64bit and in all fresh install of virtualmin (open source version), the server has had this problem. If you like, you can write to my mail account to send root access.

Hi Eric, I can confirm that the post-install wizard not work. I tried in a fresh install over Debian 8 and Centos 7 and not working. The option Re run install wizard does not appear… is missing…

Hi, I just happened to get this same issue on CentOS 6.4.

First time I’ve ever had an issue installing Virtualmin and I must have installed Virtualmin over 100 times now since 2012.

Not sure why it does this, I’ve reinstalled my VPS twice now and I am going to give it another try to see if it works.

Hi, this has fixed itself for me now, however some background for solving assistance. I didn’t see the suggestion to check the System Settings -> Re-Run Install Wizard in time to report on whether that worked.

The problem occurred after multiple re-installs of the server software (I was testing some different configs). When it first appeared, I reinstalled the OS a couple times and it was still misbehaving. I then tried playing with a couple of other control panel software offerings, and when I came back to virtualmin, the post install wizard worked. It’s almost like a ‘installWizardHasRun=1’ setting was not changing between OS installs.

In any event, it’s working fine now. Kudos on your excellent program.


Hi all,

I’m also getting this. Debian 8.4 net install with only the SSH and Systems tools options selected on install.

Installing virtualmin gpl it completes, but loses network so I have to reboot or ifup eth0. the issue then is going into virtualmin I dont get the post-install memu and cant find a way to start it.


The issue with the post-install wizard is a problem with some versions of the Authentic theme. That should be corrected in the next Webmin version. To access it in the meantime, you may need to temporarily change the theme back to the Virtualmin Framed Theme.