No Ping.

Well,

i am checking out cloudmin for kvm at the moment and was able to install it and get it up running.

Now i was able to move my vmware images over to the server, convert and load them.

I ran into following problems, which i cannot solve myself:

  1. I do not have an IP range to automatically assign the ips via dhcp; i have three vservers, which have all their own IP within one range, but by no means next to each other, so to speak: 192.168.1.1, 1.112, 1.123, 1.145

I did set the server IP’s to one of that, but it looks like the virtual machine does not honor the IP address set. Therefore the ping fails all the time and no chance to connect via vnc. I also set the IP address within the virtual machine and set the network interface to br0. Whatever i do, nothing seems to work. Any idea, please?

  1. I wanted to create a new VM from scratch with the Ubuntu image i can download within cloudmin. Unfortunately it won’t expand the harddriveimage correctly failing each time i try to create it. Then i created a new harddriveimage in my VMware Workstation, moved it ot the server, converted it, but that doesn’t work either. Also, any idea how i could get over that?

Thanks for help & best

PS: I was even able to move a Microsoft Windows Server to cloudmin; but the problem #1 keeps me from using it.

Just wanted to ask, if anybody might be able to point me in the right direction…

Hi,
nobody with any idea as of this?

Thanks for help.

Bump :slight_smile:

Sorry for the very slow reply. We usually monitor the forums a bit better than this.

What is your host OS?

I’m going to guess there is a problem with the TUN network configuration, or possibly routing problems. Routing can be very tricky to get right, if you have a bunch of different networks.

Can you post the output of:

ip addr show

And:

ip route show

And, post the configuration you have in Cloudmin for the network addresses and default gateway?

Also, the VNC shouldn’t be subject to the network working; it should be independent, and hosted on a port on the local interface. The fact that it’s not working either makes me think it is actually something more fundamentally broken, though I don’t know what it might be. I have seen a bug in the past where Cloudmin tried connecting to the wrong VLC port, though I think that bug has long been fixed… You could check the command line in /etc/init.d/cloudmin-kvm and look for the option that looks like “-vnc :12”, which means you’d connect on port 5912. You could try manually connecting to that port, especially if Cloudmin has the wrong port when you see it firing up the VNC connection. (If you do see that behavior, let me know, as it’s a bug that we’d like to fix.)