No init.d script (start/stop php-fcgi-*) created after 'Create Virtual Server'

Hello guys,

I’ve been using Webmin/Virtualmin for several years now and it was always quite a help and lots of fun. But yesterday I stumbled upon a problem which I was not able to resolve as of yet. I’m not even sure if it is Webmin/Virtualmin related, or configuration mismanagement, but I’m out of ideas at the moment.

Situtation: fresh Ubuntu installation, Webmin 1.962/Virtualmin 6.14. After initial setup was completed, I created a new virtual server. As far as I could see, everything was OK, but one thing. The php-fcgi-somedomain-com start/stop script was missing from init.d directory. I checked ‘Webmin > System > Bootup and Shutdown’ and found php-fcgi-somedomain-com.service, Starts Nginx PHP FastCGI server for (Virtualmin). (That .service part was a bit strange.) On my other server (Ubuntu 20/Webmin 1.960/Virtualmin 6.10) there was no similar problem. For each virtualhost there was a script in init.d. directory (e.g. php-fcgi-somedomain-com, Start Nginx PHP fcgi server for

Thanks in advance for your time. Any help would be much appreciated.

Operating system: Ubuntu (fresh install)
OS version: Ubuntu 20.04.1 LTS (focal)
Webmin: 1.962
Virtualmin: 6.14
Nginx: 1.18
MySQL: 5.7.32
PHP: multiple (7.3, 7.4, 8.0)


Latest Virtualmin-Nginx module version 2.18 creates systemd script.

Hi Ilia,

Yes, that was it. The latest Virtualmin-Nginx module version 2.18 was installed. I tried to downgrade to version below and it worked.

Thanks for for the quick answer and for the help

Best regards,

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.