nginx perl script bug

I got following message and I can’t do further.
HTTP/1.0 500 Perl execution failed Server: MiniServ/1.580 Date: Thu, 9 Feb 2012 18:54:29 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close
Error - Perl execution failed

Modification of non-creatable array value attempted, subscript -1 at line 107.

My server info are –

Operating system Ubuntu Linux 11.10
Webmin version 1.580
Time on system Fri Feb 10 01:25:07 2012
Kernel and CPU Linux 3.0.0-12-generic on x86_64
Processor information Intel® Core™ i3 CPU M 380 @ 2.53GHz, 4 cores
System uptime 8 hours, 58 minutes
Running processes 218
CPU load averages 0.76 (1 min) 0.67 (5 mins) 0.60 (15 mins)
CPU usage 25% user, 3% kernel, 14% IO, 58% idle
Real memory 3.74 GB total, 2.25 GB used

Virtual memory 2.12 GB total, 23.21 MB used

Local disk space 378.31 GB total, 347.91 GB used


We unfortunately haven’t performed any testing of the Nginx plugin on Ubuntu 11.10, as that isn’t one of the distribution versions that Virtualmin supports. You can see a list of supported distributions here:

However, I’ll mention the problems you’re having to Jamie. When exactly do you receive that error? Does that occur after you click a particular option?


Thanks for reply,
It happens when I click Servers->Nginx Webserver or When I try to add new server with nginx enabled.
I have noticed my server’s OS version is not supported by virtualmin but I just want to try it on.
Thanks again

In speaking with Jamie, it sounds like it’s having trouble parsing your nginx config file.

Would it be possible to see a copy of “/etc/nginx/nginx.conf”?

I appreciate that you may not wish to post that in the forums; you could also email it to if you like. If you do that, include a link to this forum thread in the message body so that I remember what it’s for :slight_smile:




I also have the error info .The version of nginx is 1.0.12 .

Thanks for the info! I think Jamie figured out the issue.

It looks like your config has multi-line directives, which Virtualmin doesn’t handle yet. That’ll be fixed in the next Nginx plugin release.

The work-around until then is to make sure directives appear on one line… for example, change:


to :

server {

and :

log_format access '$remote_addr - $remote_user [$time_local] “$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" $http_x_forwarded_for’;

to :

log_format access '$remote_addr - $remote_user [$time_local] “$request” ’ '$status $body_bytes_sent
“$http_referer” ’ ‘"$http_user_agent" $http_x_forwarded_for’;

Hi, I’ve got the same error, can someone who know what are the work around help me to correct the config file?
I’ve tried to correct the directives to be appear on 1 line, but still not working.

Can you post your config file? We’d need to see your config in order to be able to provide assistance with that.