NGinx does not restart after log file rotate

So log files is signalling nginx to reLOAD. granted. But nginx is not reLOADING on this setup it is killing it. forcing the OP to perform a restart. (in Virtualmin or with systemctl) or by delaying the reLOAD.

As I said what is making this happen on this system and not on every nginx installation?

This appears to be related to a missing parameter on the new Debian 12 support. The reload isn’t instantaneous, hence the sleep 5 parameter. I’m assuming from what is listed above is that reloading while a reload is in process is causing a problem and simply killing nginx. Notice sleep 1 didn’t work.

1 Like

In Log rotate the “Commands to run after rotation” was set to “systemctl restart nginx” so I added on that line “; sleep 5” (I did this after reading your post in this for Apache).

(sorry for late reply, was out all day.)

1 Like