Nextcloud on Virtualmin NGINX

Hello,
Here is Nextcloud’s recommended NGINX conf:
https://docs.nextcloud.com/server/latest/admin_manual/installation/nginx.html

here is a nearly default nginx conf that Virtualmin created:

server {
	server_name unique.example.site;
	listen 11.22.33.44;
	root /home/unique/public_html;
	index index.php index.htm index.html;
	access_log /var/log/virtualmin/unique.example.site_access_log;
	error_log /var/log/virtualmin/unique.example.site_error_log;
	fastcgi_param GATEWAY_INTERFACE CGI/1.1;
	fastcgi_param SERVER_SOFTWARE nginx;
	fastcgi_param QUERY_STRING $query_string;
	fastcgi_param REQUEST_METHOD $request_method;
	fastcgi_param CONTENT_TYPE $content_type;
	fastcgi_param CONTENT_LENGTH $content_length;
	fastcgi_param SCRIPT_FILENAME /home/unique/public_html$fastcgi_script_name;
	fastcgi_param SCRIPT_NAME $fastcgi_script_name;
	fastcgi_param REQUEST_URI $request_uri;
	fastcgi_param DOCUMENT_URI $document_uri;
	fastcgi_param DOCUMENT_ROOT /home/unique/public_html;
	fastcgi_param SERVER_PROTOCOL $server_protocol;
	fastcgi_param REMOTE_ADDR $remote_addr;
	fastcgi_param REMOTE_PORT $remote_port;
	fastcgi_param SERVER_ADDR $server_addr;
	fastcgi_param SERVER_PORT $server_port;
	fastcgi_param SERVER_NAME $server_name;
	fastcgi_param PATH_INFO $fastcgi_path_info;
	fastcgi_param HTTPS $https;
	location ~ \.php(/|$) {
		try_files $uri $fastcgi_script_name =404;
		fastcgi_pass unix:/var/php-fpm/1652298798410520.sock;
	}
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
	location /cgi-bin/ {
		gzip off;
		root /home/unique/cgi-bin;
		fastcgi_pass unix:/var/fcgiwrap/1652298798410520.sock/socket;
		fastcgi_param SCRIPT_FILENAME /home/unique$fastcgi_script_name;
	}
	listen 11.22.33.44:443 ssl http2;
	ssl_certificate /etc/ssl/virtualmin/1652298798410520/ssl.cert;
	ssl_certificate_key /etc/ssl/virtualmin/1652298798410520/ssl.key;
	rewrite_log off;
}

Here is how I merged them:

server {
	server_name unique.example.site;
	listen 5.9.122.103;
	root /home/unique/public_html;

    # set max upload size and increase upload timeout:
    client_max_body_size 512M;
    client_body_timeout 300s;
    fastcgi_buffers 64 4K;

    # HTTP response headers borrowed from Nextcloud `.htaccess`
    add_header Referrer-Policy                      "no-referrer"   always;
    add_header X-Content-Type-Options               "nosniff"       always;
    add_header X-Download-Options                   "noopen"        always;
    add_header X-Frame-Options                      "SAMEORIGIN"    always;
    add_header X-Permitted-Cross-Domain-Policies    "none"          always;
    add_header X-Robots-Tag                         "none"          always;
    add_header X-XSS-Protection                     "1; mode=block" always;

    # Remove X-Powered-By, which is an information leak
    fastcgi_hide_header X-Powered-By;

	index index.php index.htm index.html /index.php$request_uri;
	access_log /var/log/virtualmin/unique.example.site_access_log;
	error_log /var/log/virtualmin/unique.example.site_error_log;
	fastcgi_param GATEWAY_INTERFACE CGI/1.1;
	fastcgi_param SERVER_SOFTWARE nginx;
	fastcgi_param QUERY_STRING $query_string;
	fastcgi_param REQUEST_METHOD $request_method;
	fastcgi_param CONTENT_TYPE $content_type;
	fastcgi_param CONTENT_LENGTH $content_length;
	fastcgi_param SCRIPT_FILENAME /home/unique/public_html$fastcgi_script_name;
	fastcgi_param SCRIPT_NAME $fastcgi_script_name;
	fastcgi_param REQUEST_URI $request_uri;
	fastcgi_param DOCUMENT_URI $document_uri;
	fastcgi_param DOCUMENT_ROOT /home/unique/public_html;
	fastcgi_param SERVER_PROTOCOL $server_protocol;
	fastcgi_param REMOTE_ADDR $remote_addr;
	fastcgi_param REMOTE_PORT $remote_port;
	fastcgi_param SERVER_ADDR $server_addr;
	fastcgi_param SERVER_PORT $server_port;
	fastcgi_param SERVER_NAME $server_name;
	fastcgi_param PATH_INFO $fastcgi_path_info;
	fastcgi_param HTTPS $https;
	fastcgi_param modHeadersAvailable true;         # Avoid sending the security headers twice
	fastcgi_param front_controller_active true;     # Enable pretty urls	
    location = / {
        if ( $http_user_agent ~ ^DavClnt ) {
            return 302 /remote.php/webdav/$is_args$args;
        }
    }
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }	
    location ^~ /.well-known {
        # The rules in this block are an adaptation of the rules
        # in `.htaccess` that concern `/.well-known`.

        location = /.well-known/carddav { return 301 /remote.php/dav/; }
        location = /.well-known/caldav  { return 301 /remote.php/dav/; }

        location /.well-known/acme-challenge    { try_files $uri $uri/ =404; }
        location /.well-known/pki-validation    { try_files $uri $uri/ =404; }

        # Let Nextcloud's API for `/.well-known` URIs handle all other
        # requests by passing them to the front-end controller.
        return 301 /index.php$request_uri;
    }
    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)(?:$|/)  { return 404; }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console)                { return 404; }

    location ~ \.php(?:$|/) {
        # Required for legacy support
        rewrite ^/(?!index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy) /index.php$request_uri;

		try_files $uri $uri/ /index.php$request_uri $fastcgi_script_name =404;

		fastcgi_read_timeout 3600;
		
		fastcgi_pass unix:/var/php-fpm/1652298798410520.sock;

        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;

        fastcgi_max_temp_file_size 0;		
	}
    location ~ \.(?:css|js|svg|gif|png|jpg|ico|wasm|tflite|map)$ {
        try_files $uri /index.php$request_uri;
        add_header Cache-Control "public, max-age=15778463, $asset_immutable";
        access_log off;     # Optional: Don't log access to assets

        location ~ \.wasm$ {
            default_type application/wasm;
        }
    }

    location ~ \.woff2?$ {
        try_files $uri /index.php$request_uri;
        expires 7d;         # Cache-Control policy borrowed from `.htaccess`
        access_log off;     # Optional: Don't log access to assets
    }

    # Rule borrowed from `.htaccess`
    location /remote {
        return 301 /remote.php$request_uri;
    }

    location / {
        try_files $uri $uri/ /index.php$request_uri;
    }	
	fastcgi_split_path_info ^(.+\.php)(/.+)$;
	location /cgi-bin/ {
		gzip off;
		root /home/unique/cgi-bin;
		fastcgi_pass unix:/var/fcgiwrap/1652298798410520.sock/socket;
		fastcgi_param SCRIPT_FILENAME /home/unique$fastcgi_script_name;
	}
	listen 5.9.122.103:443 ssl http2;
	ssl_certificate /etc/ssl/virtualmin/1652298798410520/ssl.cert;
	ssl_certificate_key /etc/ssl/virtualmin/1652298798410520/ssl.key;
	rewrite_log off;
}

# Set the `immutable` cache control options only for assets with a cache busting `v` argument
map $arg_v $asset_immutable {
    "" "";
    default "immutable";
}

Any suggestions?