Newly Migrated Virtual server does not appear in Change IP list

We migrated large 32GB site there were glitches in the restore but it name appears in the virtual min servers list

But there are issues: the external ip is “stuck” on the old ip that is register with our DNs host and this new domain does not appear in the list of servers on the

Change IP Addresses

Screen. Which is where I successfully set the new ip address of some other servers we migrated

As a result we are getting errors because, for example you. Cannot preview the site on an ip outside the system

So how. Can iget this new domain to appear there? So I can assign a new IP?

I suspect some corruption in the restore process. I stopped and started webmin think this might flush and refresh the settings for this server but nothing changed. It private/ external ip is still the one on the old box.

Please advise

Also. Though aliases are set for the server in httpd conf they do not Appear under neath this parent in the virtual min list as they do in virtual min on the old machine (centos5… The new machine is centos 6.2 virtualmin390


What sorts of glitches occurred during the restore? Did you receive errors of some kind? If so, what errors did you receive?

Sometimes, a restore that large may cause the browser to timeout – if you didn’t see any errors, but are still having problems, you may want to consider using the command line tools to import the backup, rather than using your browser. You can see the options by typing “virtualmin restore-domain” from the command line.


Another man on the team was doing the migrations. I don’t know what errors he had… butI see from looking at history on the cmd line that’s exactly what he did: used the virtualmin restore-domain tool.

But what about my question? The restore finally worked, but instead of the new virtual server being assigned the default ethernet shared address for the box (which six other migrated domains did automatically) then appearing in the Change IP Address list for me to choose and assign a new IP from our block… does not appear on that list, so I can’t change the IP.

in the Edit Virtual Server options we see the virtual server is “stuck” with the IP assignment which is the current IP for this domain on the old machine… I need to change that… how? Unlike most of the screens, where there is an “edit” option to touch the actual config file on disk there is none on the Change IP Address window. I looked through everything I could think in Virtual Min and Web Min to try to find where this domain has been assigned it’s old IP… but can’t find it. It’s almost as if this server is going out to the net, getting the DNS from Zone Edit (our DNS SOA host)and using that. So, I’m stuck there…

Please advise

Well, your questions make it sound like it may not have completed the restore correctly – and knowing what errors occurred during the restore may be necessary to fix it.

However, regarding changing the IP – what if you go into Server Configuration -> Change IP Address, are you able to change it from that particular screen?

It sounds like the screen you’re referring to is in “Addresses and Networking”.


Ok I will ask mike what the errors were

I did go to the "Change IP address " screen but the newly migrated virtual server does not appear in the list for me to choose

That precisely the issue

Hmm, I’m not sure we’re talking about the same “Change IP address” screen.

There’s actually two of them… one allows you to mass-change IP addresses for all domains on the server. Is sounds like that one isn’t working for you.

However, the other one is a Change IP Address just for this one Virtual Server. You wouldn’t need to select the domain, as it’s only for this one domain.

To find that option, you’d go into Server Configuration -> Change IP Address.

Does that by chance do the trick for you?


OK I think we are on the same page now…

What’s confusing is that the domain had and assigned external Private IP, and this was for the old box and this was migrated on restore… I guess that kinda makes sense. but it’s not what happened on the other domains… anyway. this works:

  1. Server Configuration --> Change IP Address --> Switch to Shared (you have to do this because there is no field visible on the GUI to enter a new Private IP… one might consider this a “bug?”

Save… VirtuaMin is happy, runs the change

but Harumph… the screen is not refreshed… we see no place to enter a Private IP…
so, I move out to another screen… and come back

Ahaha! molto bene! Now there is a field to enter for Use Private IP address…

  1. Enter new address and save… We are good to go.

So, problem solved.

But for my edu. Since VirtualMin is a “wrapper” for a “plain vanilla linux web server” where on the machine itself are these setting saved? Most of your screens offer the option to edit/touch the actual system config files directly, but not this one… perhaps it is too ‘sensitive’ and you are helping us not shoot ourselves in the foot, which is probably a good thing, but I’m just curious. I want to go in on the cmd line and see what we are talking about.

BTW I really appreciate your attitude and responsiveness. It makes VirtualMin all that much better a tool!

Thank you!

Thanks for your kind words!

That’s some strange behavior you’re seeing though, I’ll need to do a little tinkering to see if I can find a way to reproduce it.

As far as where the settings are stored – as you mentioned, either the config files are edited directly, or the data is stored in /etc/webmin/virtual-server.

Which info in particular are you after?

A lot of the domain related data (such as the IP address) would be in /etc/webmin/virtual-server/domains.

When you go into that dir, you’ll see a lot of domain id’s – you can grep for your particular domain name.


I don’t think you will be to reproduce it. We are seeing some anomalies here because we have set up a second gateway to our place with Road Runner/Verizon to try to increase our bandwidth and we have two IP’s that are selected at random by the firewall/modem for both upstream and downstream packets. We were/are having a really hard time with XOOPS at our web site, when we go in and try and open the admin interface to edit records in different modules, wierd things happen: you can get kicked out back to the home page when we save. or some part of the form will not update, but other parts do… or you submit and the form returns with no changes… then you try again and it works

Now the main web master for that site is traveling and he’s in Austin right now and he says from there (our server is in San Francisco) he’s not seeing any problems at all.

All just guess work at this point, we don’t have the network monitoring/forensic skills to really see if this twin IP gateway is the problem or not. But since it “happens at home but not outside our firewall…” it looks very suspicious

So perhaps this is a similar behavior we are seeing in VirtualMin… or something similar. I don’t know if there is anyway in the linux fire wall on the web server to somehow treat all packets from the two IPs on our gate way as “the same” or something like that which could help… again, “Way over my pay grade!” But if it is an issue of different IPs being passed in a single session, I’m sure this is an issue others faced and solved before.