Newly created SSL certs won't work when installing php v5.3 and v5.4

I was wondering if someone could explain why when I have correctly configured my virtualmin service to use both php v5.3 and v5.4 why the SSL certificates I create for any domain are not being used?

I mean it keeps coming up with the default SSL certificate when I installed the server, like the config’s from /etc/httpd/conf.d/ssl.conf

Is there a reason for this?

I mean before I ran the install as per the instructions on this site, the domain I created the ssl configs worked.

If anyone can help that’d be great.


Just for information, I am not using multiple SSL certs on one IP address, each SSL site runs on its own IP address.

Hmm just went through a load of the group packages that were installed using grouplist and removed the ones I don’t need.

Appears to be working fine now, does anyone have a clue as to which package(s) may be causing this or is this something I missed off this site?

Any help is much appreciated in advance,


Hmm, I’m not sure what package might have been causing a problem… do you happen to have a list of the packages you removed?


Actually I don’t trying to regen the error so I can list the group of packages that caused the problem.