new user's home skeleton


I recently installed my new Ubuntu 10.04 LTS server with VirtualMin, Postfix, Amavis, SpamAssassin, ClamAV, maildrop and courier.

I’m using Maildir’s actually.

When I create a new user via VitualMin, the system creates both the “mail” and and the “Maildir” folder. So that I have :


I’m trying now to tell the server not to create the “mail” folder, because I’m using the Maildir folder. Does anybody know how to disable the creation of this folder?

In the Postfix config ( “home_mailbox” is alreay “Maildir/”
I disabled the template for the home directory, no effect.
I checked /etc/skel, but no “mail” folder.

So if someone already had a similar problem, please let me know :slight_smile:


I don’t have a solution really for this, but maybe a hint. :slight_smile:

(For me, VMin creates only Maildir. Then again, I’m using only the standard VMin packages, and no Amavis or maildrop.)

You can turn on debug logging in Webmin -> Webmin Configuration -> Debugging log file. There you can see what commands are executed, which files get created etc. Maybe that can give a hint which module creates the mail directory when (and maybe why).

Hello Locutus,

thanks for your quick reply!

Unfortunately I couldn’t find any hints in bot webmin.log and webmin.debug.

But what exactly do you call VMin Standard packages? Is there a better combination than Postfix+SpamAssassin+Amavis+ClamAV+maildrop+courier?


I meant the packages that the Virtualmin installer automatically installs. There’s no “amavis” or “maildrop” or “courier” among them, but they use Postfix and Dovecot.

I don’t dare judge if those are better than what you have installed, but I can say that they work flawlessly together with Virtualmin for me. :slight_smile:


I finally found out why there was a mail and Maildir folder at the same time.

I hunted down some code snippets in VirtualMin in the save_user procedure of VirtualMin users. And somewhere I read something about Usermin. I uninstalled Usermin to test, and bingo, no more “mail” folder.

Concerning the user’s home skeleton :

In /etc/webmin/virtual-server/config is a key : “mail_skel”. I don’t know where to find it in the VirtualMin GUI, but if you set it (by default empty), it works correctly.

Thanks for your help,

Nice find there. :slight_smile:

About the mail user skeleton: You can configure that in the Virtualmin settings, Defaults for new domains -> Initial files directory for mail users. I suppose that directory is put into the “mail_skel” entry that you discovered - but the setting only applies to newly created domains, not to existing ones (like its title would suggest too).