New users are having 'admin' appended in the middle of their usernames

I just added a new domain and went to start adding users. The process appeared to go as normal, but when I looked again at the users that were created, they had ‘admin’ inserted into the domain name, like this:

Desired username:
Actual username:

I have searched the documentation and the forums and I cannot see how or why this is happening, but it is.

Does anyone know how I stop it happening please and just create users ‘normally’ without the unwanted insertion?

Many thanks in advance.

There is no option in Virtualmin that would do that. I can’t even think of how you’d convince it to do that. :wink:

Have you modified the default username format in Webmin’s Users module? The Virtualmin email address format doesn’t allow adding arbitrary text, so I can’t think of how you could have accidentally stuck “admin” in there.

You could grep for ‘admin’ in /etc/webmin/virtual-server. That might give us a clue about which option has been set to include that (there will be some false positives probably). e.g.

cd /etc/webmin/virtual-server grep 'admin' * You might try in /etc/webmin/useradmin too, if nothing seems likely to be the culprit in the Virtualmin config.

My guess is that your browser auto-filled a form with “admin” when you were configuring something in Virtualmin or Webmin, and it got saved without you noticing. I just can’t think of where having that happen would result in the behavior you’re seeing.

Thanks for this Joe. Sadly hasn’t helped, but I have found a workaround. Is there some way of sending you info confidentially as it is only with real live data that there’s a problem and I think that you should be aware of it.



You can open a private ticket in the issue tracker, which only me, Eric, Jamie, and Ilia can see.