New users are having 'admin' appended in the middle of their usernames - private

Thanks for your help and advice so far with this.

What I think I have discovered is some kind of weirdness that I feel you should know about.

I am running Virtualmin 5.07 on CentOS Linux 7.3.1611.

I created a new VS called I gave the main username as fuelstatadmin2017 and the password as Fs2017$$$. I then went in to create other regular users of the form, etc.

What actually happened was that every time that I tried to create a user, the system inserted a gratuitous ‘admin’ into the username so that instead of, it would save as and it didn’t seem to matter what the front part of the name was, they all had ‘admin’ appended to the fuelstat part of the username.

Joe, you suggested that perhaps I had tried to do something with the username format within Webmin, but I definitely hadn’t (since I didn’t know that you could!) or perhaps that it was something in my browser cache. I cleared my browser cache and rebooted my machine and rebooted the whole Webmin server and the problem continued. I then disabled and then deleted the VS and recreated it and tried again. The same thing happened - it didn’t matter how many users I tried to create or what the username was that I was trying to create, I always got the ‘admin’ appended to the fuelstat part of the username.

So, I then disabled and deleted and recreated the VS again, only this time I made the main user FuelStat2017 instead of fuelstatadmin2017. With some trepidation, when I created a new user, it created normally. Phew! So, I was happy for me, but confused as to what had been going on. So, in the interests of science, I thought I would try one more thing. I created a new domain called I made the principal username testing1admin2017. Then I added a new user that I keyed as test1. The user that I was hoping and expecting to see was However, the login was created as test1.testing1admin2017 which means that whatever i have discovered, it is definitely reproducable.

I absolutely accept that it could be specific to my server and that there may be some corruption there, but if that’s the case, why does it not insert ‘admin’ into every username across all the VS instances on that server?