New server, receiving email OK, but can not read using UserMin / Thunderbird

I built a new server using Ubuntu 18.04 (minimal install), then added minimal kbuntu desktop.

Installed Virtualmin using the script, no issues through this process.

(All saved domains come from Centos7) - Restored all domains from old server, everything seems to be created correctly.

Postfix is receiving emails all OK, and I can read them using the Servers >> Read User Mail within Webmin.

All emails are being stored in the following location : /home/tpv/homes/test/Maildir (there are two domains sharing 5 email accounts, this was a test)

If I try and access using Usermin (which I use when away from home) it’s a blank screen for minutes on end, and when the interface does appear there are no email boxes shown. I don’t know if Usermin goes through Dovecot, but I did try every setting there to change mail delivery location, except the last one for user defined. Made no difference.

I tried creating a new email user (test) but that too was not “seen” by Usermin. I did notice that the login name had changed from test.twin-peaks-video to

I ran the command "Mail Client Configuration, said it had completed correctly. But Thunderbird does not see the configuration file when trying to create a new user. Thunderbird is also unable to connect to email.

The only error message I’m getting is from Dovecot: (I’ve checked path names etc but could see no issues there … not much help on internet for this one)

imap-login: Fatal: Couldn’t parse private ssl_key: error:0909006C:PEM routines:get_name:no start line: Expecting: ANY PRIVATE KEY
master: Error: service(imap-login): command startup failed, throttling for 60 secs

Any help would be gratefully received …


I have had this problem once or twice and I’m racking my brain trying to remember how it was fixed. I think Dibbs helped me and there were a couple of things. I think one was the SSL certificate, the other was dns.

Ensure you are using the correct SSL certificate for webmin (mine was using one of my client virtual server certs for postfix and dovecot…postfix should use the SSL (the server itself). It was a bit problematic to fix too.

I dont use virtualmin for dns. So that function is disabled/unchecked in Virtualmin>Edit Virtual Verver.

The DNS records to work with mine are A record (server public IP address) MX (server hostname.fqdn)

I don’t use the auto config script for outlook etc. I am not sure if that even works or, if it does woek, what the Virtualmin setup has to be exactly to make it work.

I’ve solved the ": Fatal: Couldn’t parse private … " problem, but now when I try to read mail from Usermin I get the message “An error occurred listing mail in this folder: failed to connect to localhost:143, connection refused”

Dovecot is running and I can use

nigel@apache-web-server:~$ telnet localhost 143
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.


Also found this in Usermin logs …

readline() on closed filehandle $ADDRESS at /usr/share/usermin/mailbox/ line 166.

Use of uninitialized value $mailbox::in{“jump”} in pattern match (m//) at /usr/share/usermin/mailbox/index.cgi line 77.

Use of uninitialized value $mailbox::in{“start”} in int at /usr/share/usermin/mailbox/index.cgi line 85.

Use of uninitialized value $mailbox::in{“start”} in int at /usr/share/usermin/mailbox/index.cgi line 85.

Use of uninitialized value in numeric ge (>=) at /usr/share/usermin/mailbox/index.cgi line 86.

Use of uninitialized value in addition (+) at /usr/share/usermin/mailbox/index.cgi line 382.

Use of uninitialized value in addition (+) at /usr/share/usermin/mailbox/index.cgi line 385.

Use of uninitialized value in subtraction (-) at /usr/share/usermin/mailbox/index.cgi line 387.

Use of uninitialized value in subtraction (-) at /usr/share/usermin/mailbox/index.cgi line 388.

Use of uninitialized value $mailbox::in{“start”} in int at /usr/share/usermin/mailbox/index.cgi line 106.

Use of uninitialized value in addition (+) at /usr/share/usermin/mailbox/index.cgi line 107.

Found the issue, nothing to do with Dovecot in the end!

I found hidden in Usermin Module Configuration - Read Mail

The first option is “Mail storage format for Inbox” and this was set to “Remote imap Server”. All I had to do was change that to “Maildir style directory :(Maildir)” and change the 2nd option to “File under home directory” … and voila, Usermin email now works.

What of course puzzles me is how the default is set incorrectly as all the setup was done by the VirtualMin script.

Still can not get Thunderbird on my PC to talk to the server :frowning: