New IP added to server but not setting in httpd.conf


Server: Linux, Centos 6.3 updated to current and current virtualmin

Have another server (verses the previous now unrelated apache issue), running well. with all sites on a single ip. Have some SSL sites so added a /28 for more space, but the address is a different range.

I have added the new addresses by adding all 12 as ifcfg-eth0:nn files and starting manually. I then went into virtualmin and added an SSL site changing it in enabled feathers etc from non-ssl and changed to one of the new IPs. Looks good. Pings ok, can ssh to the IP. But no response to web requests. Checked the /etc/httpd/conf/httpd.conf and the virtualserver has not changed from the shared address (so it is not on the ip specified (and held) in the edit virtual server/configurable settings/external ip screen/field. Have edited and tried several times but no change to the httpd.conf file.

Any ideas why the non-shared, new IP isn’t saving to the httpd.conf file?


Sounds clunky - I had a previous apache issue, this is unrelated (that server has been decommissioned).

I just deleted and recreated the sub-server - the error below is presented. The address noted here is the one saved in the httpd.conf file, but not the one selected in the dialog box.

SSL is being enabled for more than one domain on the IP address Apache on your system supports SNI, which will allow modern browsers to get the correct certificate in this situation. However, older browsers may see the first certificate for the IP, which is only valid for : *

Are you sure you want to continue?

The IP address noted is not the one selected in the dialog box (which is in the 27.50.84.xx range)

Does virtualmin only allow addresses it has setup??



To configure a domain to use an alternate IP address, you can go into Server Configuration -> Change IP Address, and set your desired IP in the “Private IP Address” field.

Doing that will immediately update the Apache config, and then you should also be able to configure that domain with an SSL certificate.



Duhh, that fixed it.

Many thanks