New HTTPS LetsEncrypt; gets cert doesnt alter apache conf

Operating system: Ubuntu 20.04

Latest everything, 6.15 etc
Just put a site live. Worked as plain HTTP.

Requested and got https via LetsEncrypt, certs successful and there. But on the front end it’s saying the cert is wrong (for another site hosted on the server)… So I went to check the /etc/apache2/sites-available/SERVERNAME.conf

There’s nothing in it for HTTPS. Its pure <VirtualHost *:80> … , the expected <VirtualHost *:443> simply isn’t there.

Is this a known bug in 6.15?!


Did you enable SSL for this domain? This should not be confused with generating a cert, first you need to actually enable SSL under “Edit Virtual Server”. Confirm that the feature is actually enabled otherwise the configuration won’t be created.

It seems in the current version of Virtualmin whether a bug or intentional, the SSL Certificate feature appears even when not enabled for the Virtual Server.

Best Regards,
Peter Knowles | TPN Solutions

AH HA! That’s the cause of this then… As I could see the SSL Cert stuff I just assumed SSL was enabled already, as normally you can’t see that menu if it isn’t. Yes, looking at it now, that’s the issue.

Thanks. Not the bug I thought it was, but still a bug.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.