New day, new problem

So I gave up on the email server part of this completely.

Around 9am this morning a lighting bolt struck the house two doors down from me and everything went boom!

We got power back about an hour later, I get everything booted up and I can’t make it to Virtualmin at all.

I searched far and wide and ultimately found that for some reason the default firewall of Ubuntu had been reactivated.

So now I can get to Virtualmin but not my websites that have worked flawlessly since I set them up.

I did a sudo apt-get update and upgrade, it updated Apache2 with something but it went by too fast for me to see.

I restarted the server and found that nothing had changed.

I ran the Recheck Configuration and it gives me this error:

The BIND DNS server version 8 or 9 does not appear to be installed on your system, or has not yet been set up properly in Webmin’s BIND DNS Server module. If your system does not use BIND, it should be disabled in Virtualmin’s module configuration page.

Then I looked at the main virtual server and saw this:

Clicking the start buttons does nothing.

The other oddball thing I did was reading one post told me to check my sites-enabled folder. There’s nothing in there but the default, so I can get to the old, original preview page for Apache server but nothing else.

The odd thing is, all the sites-available still list all the sites. It’s almost like Virtualmin doesn’t know they’re there but they’re there.

I’m really stumped. Any help would be greatly appreciated.

Virtualmin\Apache - the last time I upgraded, it previously had *:80 & *:443 or a mix (I think). It subsequent wanted either IP:80 & IP:443 or *:80 & *:443- but not mixed, if that makes sense, i.e. port 80 and port 443 both had to be IP or both had to be *.

I did put up a post in the forums here about the issue and the fix (for me). Worth a quick search on the forums.

Not even relevant to the problem. If the ports were the issue the default site wouldn’t work either. It does. Just fine. So does any newly added virtual server.

Wow! @Gomez_Adams is as indiscriminate with his flaming on these forums as Zeus was with the lightning bolt in his hood.


It isn’t an issue with ports it’s with how Apache interprets the entries in the files for each website when a mix of IP:Port and *:Port are in the files of individual sites.

Explains it and do read it properly.

All I was doing was trying to help - life’s too short to help rude, little impudent individuals.

So best of luck with all and any issues you have. :wink: :rofl:

Please use a descriptive title for all posts, @Gomez_Adams as i makes it easier for people to find topics they are most able to help with.

Im on my mobile right now so i cant do a detailed test amd therefore, I havent a clue exactly what is going wrong for you.
I have encountered the error “Bind is not enabled for this system …” in the past and on a new install its a simple fix. On yours which is an existing system…another story.

Before trying to figure out why its not working for you i will at least offer some light reading …

Also, you really need to copy and paste relevant entries from your logs. They almost always present the solution

Sorry. Didn’t know how to call it.

That’s another thing. The logs are missing. Well, not all of them but the area right here usually has Apache Log reports and other things but they’re missing:

And if you click the Webmin Actions it just says there are no actions for my user.

More observations:

I noticed on installed scripts that updates were available for a couple things so I figured I’d try to update one to see what happened. I tried to update the myphpadmin script and got this error:

This script cannot be installed, as it requires PHP version 5.

This script cannot be installed, as this virtual server does not meet its requirements : Could not work out exact PHP version, phpMyAdmin requires MySQL version 5.5 or later

But I know that’s not accurate because of this:

It’s almost as if somehow my Apache2 was completely wiped out when the power went down and no longer knows that Virtualmin is even there.

First, you do still have virtual servers on this system in virtualmin yes?

Second, I can see that apache is installed on your system (or at least virtualmin seems to think it is). The lack of the apache logs seems to me to correlate with the apache website enabled not being active in virtualmin> Edit Virtual Server> Enabled Features

Third, are you hosting your own dns, or are you using an external registrar? (i use external registrar for this, so i do not enable DNS domain…which is found in enabled features too.)

Fourth, the php5 issue…you have php 7 installed according to virtualmin. If you want to see if php5 is also installed then try looking in virtualmin>server configuration>website options> php information (just above save button)

Fifth, instead of looking for logs in virtualmin, go into SSH console directly using an editor such as Putty and use known linux commands for your operating system to check log files…or even navigate to the logs via file manager in ether webmin or virtualmin.

Finally, if all else fails, have you tried to re-run the virtualmin installation wizard? (its in virtualmin>system settings> re run install wizard)

The wizard isn’t gonna do anything useful. It just sets some configuration options.

Re-check configuration and Validate virtual servers is a better instinct for things to reach for when things are weird, but that won’t fix this either.

But it sounds like OP has lost his virtualmin domain configs, which is…bad. If you don’t have backups, you’ll just have to use the Import function for each of the domains, and then manually cleanup/configure whatever is missing/wrong.

I’ve edited a comment in this thread to remove hostile language, and I see a couple of others that could probably use an editors hand. Everybody simmer down a bit, please.

If you can’t keep it friendly, go for a stroll outside. Problems have an annoying habit of sticking around, so it’ll probably still be broken when you get back. I know computers make everybody mad, but we’re stuck with them, might as well be nice to each other while we beat the machines into submission.

@Gomez_Adams the fact that both the “check configuration” gives you an error saying that bind is not installed, and clicking the start button on the dashboard does nothing, effectively indicates that the bind server is not installed (even if the webmin module is).

Webmin / Virtualmin modules are different things and separated from packages; if you run the “check configuration” on virtualmin or in whatever module you clicked that button that gave you that error, and then you clicked on “BIND DNS Server” module link, you would have been redirected to the bind webmin module, that would probably have yelled at you reporting that bind is not installed, offering a button / link to install it directly (or just installed it for you by automatically redirecting you to the “update / install packages” module).

Also, I don’t think a power loss can ever break symbolic links (the ones that you usually create from sites-available to sites-enabled), nor it can break virtualhosts configurations; but, nevertheless, if virtualmin cannot recognize and pick up in it’s web UI your virtualhosts, they’re not so many, and you’re willing to put time and effort into it, you can SSH into the machine, copy everything is inside sites-available (except for default.conf or however it’s called) to your home directory (being it /root/ or /home/something/), remove them from their original location under /etc/apache, and with both the console window and the web UI opened, copy them one by one into virtualmin’s configuration.
Also, to make sure a power loss will not randomly clear your configs again, just to make sure, reboot the server once you’re done; so you’re 100.00% sure that no matter what happens, your config files are saved, flushed, applied, and a reboot (being it manual / scheduled for maintenance or a power loss), won’t clear anything again.

This was all solved 2 days ago. Why people are still beating this thread to death is beyond me.

I’m really really sorry if I tried to be helpful.
Your last two posts talk about missing logs, and the last image of your control panel you sent still had BIND not installed (or at least disabled / not running).

Did you tell anybody on this forum that you solved your problem? no
Do you criticize people for still trying to help you for God’s sake? yes

Please, STFU and keep your problems for you then, this is how a forum works, people try to help, and you either plainly (and almost disrespectfully) deny the try

or you just randomly reply with seemingly unrelated behaviour like you were not the one seeking for solutions and asking for help like you were not the one in trouble like etc etc etc…

What’s wrong with either your thinking of what a forum is or you yourself? (you decide)

Yes, I did say it was fixed. I told Joe himself that Calport was working on it.

That’s the last comment I made to anybody on this forum until today when I got 9 emails about this thread from two days ago.

Not on this thread tho, not on this thread bro…

We’re not all Joe :wink:

This thread was closed. There was no need to.

Then, for whatever reason it was opened back up again today just in time for you to comment on it.

So, once again, just for you, it was solved by the guy in this very thread with the full knowledge of the administration.

Thank you for your efforts at any rate.

I don’t think anybody knew this was resolved (not even me). I was never marked “Solved”, so it didn’t auto-close. But, I’m glad it is. It’s too grouchy.

I’m closing this topic, so we can move on.