Netplan - Webmin / Virtualmin bug

Operating system: Ubuntu Linux 20.04.2
OS version: 20.04.2 LTS Cloud server

Hi Guys,

When updating IPv4 and or IPv6 to static interface records Netplan isn’t holding the setup after a reboot and reverts back to DHCP. I’ve switched off DHCP on the cloud VMnet that the server is on, so it shouldn’t be due to a cloud agent conflict but it looks like cloud-init isn’t giving up.

From the 50-cloud-init.yaml
This file is generated from information provided by the datasource. Changes
to it will not persist across an instance reboot. To disable cloud-init’s
network configuration capabilities, write a file
/etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
network: {config: disabled}

I’ll sort out the YAML manually but I guess this is something you’ll want to fix, there should be an option to disable this within Webmin/Virtualmin?


Also, additional routes added within the webmin / virtualmin interface are not persistent?

For anyone wanting to add these in persistent state manually Best YAML Validator Online works well to check markup.

They can be dropped into the .YAML file in etc/netplan as so:

        set-name: eth0
            - to:
            - to:

Then load the config

$ sudo netplan apply

:+1: :+1:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.