Need Help with PostFix on Ubuntu

We are migrating sites to Linode Cloud servers using VirtualMin. So far so good. glitches along the way are being solved. but the new “boxes” come with no MTA configured.

I ran

apt-get mailutils
apt-get sendmail # may as well have two options

then went to WebMin --> Servers --> PostFix

WebMin said something had yet to be installed… so I ran that

then tried this from terminal:

echo “this is a test from Postfix” | mail -s “Testing Mail From ShivGurudeva”

And… YAY! I got a mail message in the queue that never leaves the box (hehe) from (the host name)

and now I am waaaay out of my depth. Mail is there ready to go, but doesn’t actually go out.

If you think you can hand hold me thru the config from here… please do…or point me to documentation.

Or email me off list: and if you are an ubuntu config wizard I’ll pay you for a few hours work to help get this working…

Looks like you are missing mx records - Did you check your logs? There you could find some info what is going on.

Good point. Actually Postfix is set on the old box with a localhost name of “” with an MX record that points to the main IP on that dedicated server (and not a A record as such) So you can’t look this up and an MX record is not really required for outgoing mail to work.

But, you are right, we do need to add to the zones for these domains the outgoing mailer records. I had forgotten about that!