Need help to bind usermin where I want


I have a domain, let’s call it In the DNS zone, I created a subdomain and I put on it the address And I want it to use standard https port, 443.

I would like to bind usermin to this IP and port, but I cannot… it always says in miniserv error log :

Address already in use at /usr/local/usermin-1.290/ line 407.

How comes? And how can I bind it to this url in https mode?

I decided to switch from squirrelmail to usermin, but squirrelmail is a simple webmail and it is easy to configure it this way… I just have to put squirrelmail folder where I want it to, create an apache vhost config with this IP and http port, with the good root document, and that’s all… and with usermin?


Hey Julien,

By creating a virtual server there, you’ve taken the port for Apache. Usermin doesn’t run under Apache, and the two can’t share an IP:port combination.

So, disable SSL for that domain, and then restart Usermin.

Usermin is happy to run on any port you tell it.

Thanks for your help. I tried something… I stopped apache, I changed usermin ports, and start usermin, and it worked… fine…

Then I started apache again and I had the error :
(98)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down

So it seems my address is in conflict with the address How is it possible and how can I fix it?

You say removing apache ssl, but just for IP, right? Where do I do that?


Ok I found… thanks to webmin was easy to disable SSL for my webserver :slight_smile:
I can promise nothing but in a few months when my boss will see the power of the new website, I’ll ask him to make a donation… or to buy the pro version ^^ btw what’s the differences in the pro?

'night, time for me to sleep, it is past midnight here in france…

Differences (most of them) are documented here: