Need Help : Multiple PHP Versions, unable to update/remove PHP54

Hi there,

A while back I installed an extra version of PHP in my virtualmin box in accordance to

http://www.virtualmin.com/documentation/web/multiplephp

Unfortunately I was unable to update or delete the installation since the Repo do not exist anymore.

==========================================================================

[root@web opt]# yum update php54 php54-php-cli php54-php-mysql php54-php-gd
Loaded plugins: fastestmirror, protectbase, refresh-packagekit
Loading mirror speeds from cached hostfile

  • base: mirror.upsi.edu.my
  • epel: epel.mirror.srv.co.ge
  • extras: mirror.upsi.edu.my
  • updates: mirror.upsi.edu.my
    http://people.redhat.com/rcollet/php54/rhel/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”
    Trying other mirror.
    111 packages excluded due to repository protections
    Setting up Update Process
    No Packages marked for Update

===========================================================================

[root@web opt]# yum remove php54 php54-php-cli php54-php-mysql php54-php-gd
Loaded plugins: fastestmirror, protectbase, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
–> Running transaction check
—> Package php54.x86_64 0:1-7.el6.2 will be erased
–> Finished Dependency Resolution
http://people.redhat.com/rcollet/php54/rhel/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: php54. Please verify its path and try again
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

==============================================================================

Please help.

hazmi.

I came by looking for info on how to install 5.4 alongside an existing 5.3
And indeed the repo mentioned no longer exists so +me too for this.

Howdy,

We’ve been in the process of testing a different repository that supports Software Collections like the previous library that was in use.

I just updated the documentation to make use of it – take a look at what’s here now, and see if that works for you:

Take a look at the updated documentation here, and see if that works for you now:

http://www.virtualmin.com/documentation/web/multiplephp

I just came back to say:
yum install centos-release-SCL
yum install php54 php54-php-whatever-else-you-need

but you beat me to it!
anyway, yep that works for me, and the new versions show up in configuration as advertised

Dear andreychek,

Ok I have removed the previous repo of “software_collections_php54.repo” and follow the new instructions. Then I do a “yum clean all” then “yum update”. It seems to work perfectly.

But when I want to install something for example php54-php-ldap I encounter the following problem :

====================================================================== [root@web ~]# yum install php54-php-ldap

Loaded plugins: fastestmirror, protectbase, refresh-packagekit
Loading mirror speeds from cached hostfile

  • base: centosc6.centos.org
  • epel: buaya.klas.or.id
  • extras: mirror.upsi.edu.my
  • updates: centos.mirror.serversaustralia.com.au
    113 packages excluded due to repository protections
    Setting up Install Process Resolving Dependencies
    –> Running transaction check
    —> Package php54-php-ldap.x86_64 0:5.4.16-7.el6.centos.alt.1 will be installed
    –> Processing Dependency: php54-php-common(x86-64) = 5.4.16-7.el6.centos.alt.1 for package: php54-php-ldap-5.4.16-7.el6.centos.alt.1.x86_64
    –> Finished Dependency Resolution

Error: Package: php54-php-ldap-5.4.16-7.el6.centos.alt.1.x86_64 (scl)

Requires: php54-php-common(x86-64) = 5.4.16-7.el6.centos.alt.1
Installed: php54-php-common-5.4.16-7.el6.1.1.x86_64 (@php54) php54-php-common(x86-64) = 5.4.16-7.el6.1.1
Available: php54-php-common-5.4.16-7.el6.centos.alt.x86_64 (scl) php54-php-common(x86-64) = 5.4.16-7.el6.centos.alt
Available: php54-php-common-5.4.16-7.el6.centos.alt.1.x86_64 (scl) php54-php-common(x86-64) = 5.4.16-7.el6.centos.alt.1

You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

==============================================================================

Please advice.

ahhh…
]# yum install php54-php-mcrypt
]# No package php54-php-mcrypt available

why?

and now I come to look at this; SCL is actually providing 5.4.16 which is way behind current including important security releases behind.

So is there a different way to get an up to date multi version install of PHP 5.4 ?

5.4.16 is maintained by RH, just like 5.3.3 is. They should be releasing updates soon.

point taken on the updates, but there is still no mcrypt with rh scl repo.

but I spoke with remi collet on irc who was incredibly helpful and provided an rpm within minutes.

honestly the guy is a hero - If you ever used remi collet repos I urge you to go and make a donation to his server fund.
http://rpms.famillecollet.com/

point taken re the updates, but the rh scl repo doesnt provide mcrypt.

But I talked on irc with with remi collet who was incredibly helpful and provided an rpm within minutes!

Honestly the guy is truly a hero. If you ever used a remi collet repo I urge you to go and make a donation to his server fund

http://rpms.famillecollet.com/

Thanks for the explanation!

The following problem occurs after installing mcrypt from the rpms.famillecollet.com: FastCGI is broken. When I do set the rpms I notice that PHP5 is updated to the last version automatically using that repo.

When the Virtualmin options are set to use FastCGI PHP doesn’t work anymore and a blank page is rendered when opening up a php-file. When changing Virtualmin to use mod_php it starts working again. The problem that occurs for me is that when the server is set to mod_php I’m unable to set a specific version for a Virtualmin virtual host.

Any idea how to fix this?

Thanks.

Hi, I’m running Centos 5.7 - edit: ahh that was for Centos 6. Regardless, what is the latest on how to get a newer version of PHP onto my Centos 5.7 box with an up to date Virtualmin? Thanks

I followed the document instructions but unfortunately I get this message:

yum install centos-release-SCL

No package centos-release-SCL available.

and then

yum install php54 php54-php-cli php54-php-mysql php54-php-gd

No package php54 available.
No package php54-php-cli available.
No package php54-php-mysql available.
No package php54-php-gd available.

I’m on the same boat! Did you find a way to provide mcrypt for PHP 5.4?

I posted a separate question before I saw yours here https://www.virtualmin.com/node/33964 (see updates on my situation there)

PS: I followed these instructions to install PHP 5.4 alongside 5.3.3 on CentOS 6.5: https://www.virtualmin.com/documentation/web/multiplephp

Hi Eddie,

I’ve fixed the issue using this information:

http://forums.famillecollet.com/viewtopic.php?id=1871

FIXED. See https://www.virtualmin.com/node/33964#comment-136190