Namserver issues, I think


Ok i have a static ip, and one ubuntu box.

I have installed virtualmin and all seems ok (no errors or warnings)

I have registered the domain (lets call it with godaddy, yeah hindsight.

In the a record on godaddy I added ns1 and my ip address. I also added ns2 (and changed the @ to point to my ip address)

Have it a couple of hours and I could connect to

Everything good so far, obviously I am seeing /var/www/

I add my a records ns1 and 2 pointing to my internal ip (virtual)

I can ping it shows external address (godaddy dns?)

I browse to and I still get /var/www not /home/pita/public_html/

Any hints as to what I am doing wrong? I just want to host the one personal domain (at the moment)


If I use lynx and browse internally to it’s virtual ip I get a 403 I presume that’s expected

Ok. I now have it setup that when I ssh in and ping I now get get replies from it’s virtual ip, but when I browse to the address I get the apache placeholder from /var/www

Ok fixed it I think, don’t know what I did though, how through are virtualmin logs?