Nameservers not responding and cluster slave server problem


I successfully set up BIND under Webmin to resolve a domain (call it That was last night. Now I get the nameservers not responding error. Not sure why it worked last night but not today.

Today, I set up Virtualmin on another server to use the server above as a cluster slave server. Firstly it would not connect, because of the lame nameservers on the remote server above. So, I replaced the with the actual ip address and it did connect. It transferred the domains from the Virtualmin server to the remote slave Webmin server. These now appear as slave zones under Webmin on the remote server. But, these slave zones still have not transferred the records from the Virtualmin master server.

So, I have two problems:

  1. Lame nameservers at the remote Webmin server. This is for a zone ( where the remote Webmin server is acting as master.
  2. The remote Webmin server is not transferring the records from the Virtualmin master server.

Any ideas would be great!

As an update. I have now installed Virtualmin on the remote Webmin server (this is a VPS). Virtualmin reports that everything is configured correctly, but I’m still getting the ‘nameservers not responding’ issue. I had to uninstall Sendmail and install Postfix instead, but hey, Virtialmin is at least reporting that everything is okay.

I am able to transfer records from this remote server to another local server using the cluster slave server.

Can someone cast some light on what could be causing the ‘nameservers not responding’ issue? I have set up the zone (call it using Vurtualmin now, so it should be configured correctly???

As another update,, i.e. using the ip address for the remote server and go to the /var/www directory. But, goes to the new /home/ directory.

I just thought you might like to know it is now all running smoothly (I think!).

I am running Ubuntu 9.04 and had tried to install Virtualmin manually. As you can see from the above - I had problems.

So, I decided to reload my Ubuntu 9.04 and install Virtualmin using the automatic install script. I hadn’t done this before because Ubuntu 9.04 is not a supported OS for the install script. In fact, it seems to have worked very well.

My domain is now resolving and Intodns don’t report any DNS errors.

I will now set up the cluster slave servers…