MySQL Support Missing

Still working on getting my Virtualmin 3.64 gpl on Debian etch up and running. Today’s challenge is the MySQL database. MySQL is running on the server as I can attach to it from phpmyadmin and the virtualmin control panel. I imported a database and everything seems ok, but my software cannot see the database. (Drupal and CPG Dragonfly) When etch was installed only the bare minimum of software was included. Apache, MySQL, PHP, etc were all installed by the Virtualmin installer.

I poked around in the forum looking for a similar problem and found this thread, which seemed to fix at least part of the problem. After I edited the /etc/php5/apache2/php.ini file, the software can now see the database. PHP5 was already installed. (I don’t know why editing the php.ini file isn’t part of the install)

So after that long post I finally get to my question. I found this thread on the same subject where Joe says:

In short, you need to make sure the Webmin MySQL module knows where MySQL lives and is able to connect to it as the root user–you may need to provide the password to Webmin. So, browse to the Webmin:Servers:MySQL Database Server module, and see if things are working there. Virtualmin only knows about services that Webmin knows about.
When I follow the same path there is no MySQL Database Server module. I’m not sure if this is a problem or not or is it part of the paid version of Virtualmin?

I suspect the message you see is referring to a given Virtual Server not having MySQL support enabled.

If you log into Virtualmin, then click the domain from the dropdown, and select Edit Virtual Server -> Enabled Features, is "MySQL login enabled" checked?
-Eric

Thanks for the reply… yes this is checked. Both on the Admin configuration and the individual Virtual Servers.

Okay.

When you go into System Settings -> Features and Plugins, is MySQL database is checked?
-Eric

You should have a MySQL module, Pro or GPL.

If it’s not working properly, you may be able to find it within Webmin -> Un-used Modules.

If that doesn’t work, I’d recommend using Webmin’s search to find it, as it should be there.
-Eric