Mysql error on script install


I’m getting the following error installing or upgrading some scripts on some sites. For example

These might(?) be sites installed from vm backups on another box

I’ve run mysql_upgrade just in case. no errors or updates required
I’ve reset vm password and mysql password
admin_user has mysql access from shell. ie:
mysql -u admin_user -p
works with existing vm admin_user password
I tried granting privileges on any host (grant all … admin_user@% …)

but still the same error.

any thoughts on a solution please?



still seeing this error and I cant find a solution - except deleting the domains and recreating, but I cant do this for some.

as above mysql and the user seem to check out ok if outside virtualmin script update.
I’m kinda thinking it might be some sort of password encryption issue - but where?

anbody got any suggestions please?

I don’t known. Installing roundcube 0.6 with Virtualmin worked for me, as did an update to 0.7. As it happened I had already installed from the Debian repo with apt-get. There are other methods of installing.

But since Virtualmin’s script installs roundcube on a per account basis, you might try creating a new account with new username and password, and seeing whether the script will run for the new account.


thanks for reply
it isnt just Roundcube - it happens with other scripts too… joomla piwik at least on those domains that I’ve tried

new scripts installs on new domains are OK.

I’m pretty sure the problem is just script upgrades on existing sites, and I’m also pretty sure those sites were backed up and restored from another virtualmin box.

As far as I know there arent any other problems. And for example on a domain that wont upgrade Joomla because of the mysql error, the joomla site is running fine so the user db access is ok.

I cant figure it out.
Good job it isnt mission critical! but it will be good to get it fixed.

I am no Virtualmin expert, but I guess I would be looking at the php setttings in the other sites, and probably making the php.ini files consistent across the board (subject to any different software used on their websites). I would first have a quick look around at folder ownerships and permissions too, and ensure that the imported site owners have been correctly set up as not only mysql users but also as unix / linux users.

I posted about this in another recently but I’m raising this thread of my own again.

I had previously thought that this was for some migrated sites only, but it isnt. Its the same for any site on the box.

There is NO problem for the mysql user

as I posted in the other thread:
I’ve reset vm password and mysql password.
There is no problem with admin_user access for db. I can login and out of mysql via cli or a simple php script no problem.
admin_user has mysql access from shell. ie: mysql -u admin_user -p works with the existing vm admin_user password
I tried granting privileges on any host (grant all … admin_user@% …) But no success

I can install (for example) joomla or any script manually on any site and it will work fine every time.

but equally any script install on any site via the VM installer will fail every time.

@john - thanks for yor opinion but it doesnt appear to be those things.

@locutus from the other thread
thanks also. you are correct about ‘old-passwords’ thing, but that isnt the problem either.

This is centos 5.8 with mysql 5.5.24
vm 3.91 and webmin 1.585

I’d like to find a fix now, so any input will be gratefully received


found this:
and it fixes it!

so why is that then?