mySQL database users

I tried to do a mysqldump of one of the databases created with VM withing a virtual server. I tried using ‘root’ as the user and the root password for password but get an authentication error.

Are the databases created with root (or the user running VM) as an administrator? I’m assuming that if I try to create an inital database within VM at install time that I will run into the same permissions issue.

Is there a setting I’m missing to have ‘root’ as a valid user for newly created databases?

thanks,
tony<br><br>Post edited by: tbirnseth, at: 2008/11/20 07:53

The root user should have permissions for all databases.

I suspect it’s just a password issue, perhaps you’re typing it incorrectly or had changed it somewhere along the lines?
-Eric

I believe I’m typing ‘root’ and the password correctly. I can dump the DB if I use the admin name/password of the created virtual server. But doing it as root does not let me authenticate.

Is there a way to do a ‘mysql’ on the mySQL db configuration to ensure that root has access to all databases? Maybe it’s a restriction imposed for security?

Went in under webmin and changed the ‘root@localhost’ password and now it seems to be fine… Very strange…