My website isn't secure

How can I solve this, my https://techgainz.com having an error whenever I open it, it says connection is not secure.

You probably need to apply a SSL certificate to the virtual server / domain.

You could buy one or get a free certificate from Let’s Encrypt via Virtualmin.

To get a free SSL certificate via Virtualmin, you must:

  1. Enable SSL for the virtual server via Virtualmin → Edit Virtual Server and then check the box captioned SSL Website Enabled

  2. If you are using a third party DNS service provider, then point the mail, webmail, admin and www subdomains to the IP address of your Virtualmin server - give it time to propagate.

  3. Apply the free Let’s Encrypt certificate via Virtualmin → Server Configuration → SSL Certificate

Looks fine to me.
Screenshot from 2022-11-17 01-32-23

Yup, looks fine to me too. Hey @HKhan12, you have the lock symbol showing on your website. Yay!