My nginx is stopping by itself, several times a day!

My nginx is stopping by itself, several times a day!

Hello guys. I am in a tightening, I am in trouble, time and other my sites are offline, when I go to check my nginx server is stopped, I call again, when it is a few hours later, the time varies a lot, it again, I have to send one and this is a vice that lasts almost a month. I’ve been analyzing, there is no precise time, so it’s not a crazy cron, people what do I do? I use ubuntu 16.04 / 32 + WEBMIN / virtualmin + nginx + php7.0-fpm + mysql 5.7. I did not do anything on the server by the time he started it !! It is not about load, because I have little access and a lot of resources left over, I worked a lot configuring this and suddenly about 2 months after I finished configuring everything, the server starts that this crazy behavior: '(Would it be something in some webmin update? I have a VPS with ubuntu 14.01 where it to infrequently, but mysql is stopping !!! Thanks all.

Check the kernel log for OOM (out of memory) messages. This sounds kinda like a memory issue. If this is a Virtuozzo or OpenVZ container, it would be a little harder to track down, but because hosts can oversell memory on those systems without telling their users, memory problems are super common, and they look different than they would on a physical system, or a KVM or Xen virtual machine which allocates memory differently. So, if this is a Virtuozzo/OpenVZ host, check the /proc/beancounters and /proc/user_beancounters for clues…but, if it’s one of those kinds of VM, I would put very good odds on it being memory related.

Also, check the nginx logs for indication of why it is shutting down.

It has nothing to do with Webmin or Virtualmin updates. I’m absolutely confident of that. Though, you may want to follow the Virtualmin on Low Memory Systems guide to reduce your memory usage to see if it helps reduce the frequency of shutdowns for your services.

Thanks for replying, I added memory swap in vps with nginx, had 2g increased to
4g, and increased the priority property by 20%, and also removed a duplicate gzip over text / hml and text / plain settings in the nginx.conf file, in the nginx log said this duplicity with the text / html, I removed text / Html. Pat that stopped the bug. I think super strange I have been wrong about this, and nginx have this behavior of starting the service without errors in the console, and have a silent error in the log: / In my opinion neither was it for the service to start … And in the other two VPS with apache , Where mysql was stopping many times, I configured so basically, simply and directly, that I had not even created swap memory !!! What !! In this two new vps. Mysql was stopping several times a day, one of them was not possible to increase swap memory because it is a vps without great previews in the crap of host1plus, vps useless, without any privileges in root: / I will leave them (I will rent a very small and cheap In ovh only for tests, good performance but bad bugs in ovh, only for tests), and for this vps of H1P, I modify max_connection in my.cnf and it seems that the services stopped with the terrible stops. Thanks for reply… my log on syslog: http://