Multiple websites behind firewall

Due to a RAID failure, we’ve had to rebuild our web server. It worked fine behind our NAT router before and No changes have been made to the router. The only difference is the new installation of CentOS 5.6 & Virtualmin & Apache is configured to host SSL websites. We’re hosting five web sites. Behind five tried the internal and external IP address for the default ip for virtual servers. I cannot figure out what I’m overlooking.
Here is the output of the recheck configuration:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

BIND DNS server is installed, and the system is configured to use it.
Mail server Postfix is installed and configured.

Apache is installed.

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin DAV Login is installed OK.

Plugin AWstats reporting is installed OK.

Plugin Mailman is installed OK.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

IPv6 addresses are available, using interface eth0.

Default IP address for virtual servers is xx.xx.44.41.

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… your system is ready for use by Virtualmin.

Any help is appreciated !!!