Multiple phps installed as per guide - Virtualmin is not recognizing 2nd

Hello,

USing Virtualmin GPL, and following this guide here http://www.virtualmin.com/documentation/web/multiplephp

I managed to install fine php52 with a software collection from here http://alanthing.com/blog/2013/07/11/creating-php-packages-software-collection/

Verified php52 runs fine under /opt…

When I go to Virtualmin, the recheck config step does not recognize the 2nd php, that is 52. Any tips?

Looks like Virtualmin doesn’t support anything older then 5.3 as a selectable version, I see support for 5.3, 5.4, & 5.5 in the code.

In the interim you can just change the path in the php5.fcgi file for each virtual site you want to use 5.2

Thx lp86, wonder if Joe and Andrey would consider expanding this for older versions as well? :slight_smile:

I’ll bring that idea up for discussion with Joe and Jamie.

The issue though is that PHP 5.2 is no longer supported by the PHP developers, so that means installing it involves installing a PHP version that isn’t getting security updates… and that idea makes us uncomfortable :slight_smile:

-ERic

I guess a warning could popup saying old and insecure php version detected. :slight_smile: It would help a great deal in migrating some of my old sites to use Virtualmin with the multiple php magic :slight_smile: