Multiple PHP versions not working

I’ve installed Virtualmin on a clean installation of Ubuntu 18.04. As part of that installation it installed PHP 7.2. I needed 5.6 for an older program I run so I installed the Mulitiple PHP feature. Everything looked like it worked well. When I went to switch versions of PHP on a server it said that everything worked. But when I went to use it everything except version 7.2 failed. So something is not configured correctly when it installed. It’s not just failing to switch versions, it’s actually disabling PHP all together except when I switch back to PHP7.2 then it works fine.

HELP! I’d rather not reinstall everything!!!

Have you have re-checked configuration after installing PHP 5.6 via Virtualmin -> System Settings -> Recheck Configuration? It is imperative that this be done when adding / removing different versions of PHP.

What do you mean by ‘failed’. Please tell us more…

That was the answer! Thank you for the help!

Dan Lewis

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.