Multiple PHP Versions - Installing Mcrypt

Hi All,

I am trying to install Mcrypt on the new secondary version of PHP I installed on CentOS.

Mcrypt is already installed on version 5.3.3 and works, but the script I am using needs a newer version of PHP. So I have installed 5.4.16 on CentOS as a secondary PHP version, which I select from the Virtualmin > PHP Versions menu.

Question is, how can I install a new package to this new PHP version, as when I try YUM Install it says it already exists (as its on the older version).

There is no mcrypt for centos 6 and php 5.4. You can compile your mcrypt for php 5.4 (good luck with this) or use 5.3 as default and then call 5.4 for your software. Still some scripts like phpmyadmin will need to work on 5.3 but you could set 5.4 with htaccess for your forum (example). Or just install centos 7 and problem solved.