Multiple PHP-FPM versions, pool.d ports issue


Wherever I change PHP version for the vhost a new config being created under /etc/php/php.x/pool.d directory with random port causing duplicate ports issue. Another issue is that I need to edit apache conf for the website and change: SetHandler proxy:fcgi://localhost:8042 to match php-fpm port for each vhost

My questions are:

  1. Is there any script which checks for duplicate ports and fix both pool.d and apache for each port in all PHP versions?
  2. Once the version PHP switched should the previous pool.d config be deleted?


This mustn’t be happening. What OS and version are you running it on?

Does re-running config check changes anything?

I’m running Ubuntu 20.04 re-check does not fix the issue. I have to edit config manually and fix the ports.

Can you upload /etc/webmin/virtual-server/config file? It would be easier if we could reproduce the problem locally.

Beware to remove all password strings in that file, with 123.

Attached, thank you
config.ini (8.8 KB)

If you go to System Settings ⇾ Server Templates: Edit Server Template / PHP Options page, check it all right and click safe. Does it change (fixes the issue) anything on your side? If it does, can you re-upload the updated config once again?

@miojamo, if you feel comfortable, try applying this patch, restarting Webmin and see if this solves the issue for you.

1 Like

Looks promising. I’ll test it thanks,

Yup localhost isn’t “always” the same as and such things goes wrong more often. :wink:

Good to see you solved. :wink: I guess.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.