Moved virtual server [Solved]


We moved our virtual server from one Virtualmin installation to another (on a different IP) and changed the DNS entries to point the to the new IP (all sub-domains including znd, MX records are set to We tried disabling the virtual server in question on the previous virtualmin installation as well and DNS enteries were changed more than 72hrs back…

The website etc is working fine from the new server i.e. we see that the traffic for is now served from the new server. But the emails are still being sent to the old server…

Are we missing something? Is there anything else that we need to do in order to tell the new server to start reciving emails for this virtual server that we have restored from the previous machine?

I am not very sure of the issue, so if you need any more information to help us out, please let us know …

Dheeraj Juneja<br><br>Post edited by: dheerajjuneja, at: 2008/08/14 01:18

It’s almost certainly a DNS issue.

Are you glue records now pointing to the new server (and its slave(s))? If they’re pointing to the old server, and the old server has only had some of its records updated in the zone, some services could still be pointing to the old server.

Run through our DNS troubleshooting docs:,dns_troubleshooting/

Check to be sure you don’t have any extraneous hosts file entries on the new server that might cause forwarding to the wrong system.

Check the maillog on the new server to see if anything is coming in, and either being forwarded on incorrectly or bounced.

Check the Postfix configuration on the new system to be sure you haven’t configured it to relay mail to the old server…sometimes this can happen in places you wouldn’t expect. The “myorigin” parameter, for example, does not do what anyone, anywhere, ever, expects it to do…if you have it set it will cause trouble.

most likely a dns cache issue

in linux you can clear out any cache using ‘rndc flush’

There is one thing that I am not getting, maybe its beyond my knowledge at the moment.

If i ping for "" i see the new IP.

The MX record is set to send mail to "", then how come doing anything on the old server change mail routing?

as in the old server should not be coming into picture at all … ?

If you do a “whois” on, you’ll see a series of nameservers listed within the whois entry (those are the “glue records” Joe was talking about).

Those nameservers need to be pointing at your new server, or else they could be retrieving data from the old server. If the nameservers are they same as they were before you moved, that means you’d need to log into your registrar, and update where the IP’s for those nameservers point.

Yup, Its sorted out.

Though I changed nothing, but i think 72hrs were not enough to start pointing to the new server.

Thanks for all the information guys … truly appreciated.