More user-friendly quota bounce message

When mail is bounced back to the sender because the receiver has exceeded their quota, the message that is given isn’t very user friendly. I can’t seem to get the following message to say “Quota exceeded”. It just shows “can’t create user output file” which doesn’t tell the sender anything really.

Example:

russell-example.com@server2.example.com (expanded from
russell@example.com): can’t create user output file

Any idea how to change this?

I’ve just experienced the same issue of trying to track down a mail fault and eventually traced it back to the account being over quota.

Was a issue raised in the tracker about this?

Dave

Well, it’s another few months, and now I have the same question.

I’ve tried to search using combinations of postfix and procmail as queries on the ol’ web, and I’m getting nowhere.

Is there a way to change this, and is it a postfix generated message, or procmail?

Thanks,

GS

My solution was:

  1. Setup Dovecot LDA (http://wiki.dovecot.org/LDA)
    postmaster_address = postmaster@domain ## required
    mail_plugins = quota
    mail_plugins_dir = /usr/local/lib/dovecot/lda
    quota_full_tempfail = no

    and necessary description of bounce (see in Dovecot config)

  2. Feed incoming e-mail to Dovecot LDA via procmailrc (named deliver).
    It looks like this:
    LOGFILE=/var/log/procmail.log
    TRAP=/etc/webmin/virtual-server/procmail-logger.pl
    :0wi
    VIRTUALMIN=|/etc/webmin/virtual-server/lookup-domain.pl $LOGNAME
    :0

  • ?/usr/bin/test “$VIRTUALMIN” != “”
    {
    INCLUDERC=/etc/webmin/virtual-server/procmail/$VIRTUALMIN
    }
    DEFAULT=$HOME/Maildir/
    ORGMAIL=$HOME/Maildir/
    DROPPRIVS=yes
    :0 w
    | /usr/local/libexec/dovecot/deliver
    :0
    $DEFAULT

After that incoming mails will be processed by Dovecot deliver LDA that will use Dovecot quota settings.
How to setup quota you can see in my recent post:
http://www.virtualmin.com/node/11217#comment-48764

PS: work well with FS quita type.

Thanks,

I’ll take a look at what you have provided. At first glance it appears a bit overwhelming, but I’ll do some research and get it figured out. Thanks for the assistance.

GS