Moodle 3.3 install issue


I was trying to install Moodle 3.3 it makes no difference if I use the virtualmin install script or the moodle install files I get this.


Your database has tables using Antelope as the file format. Full UTF-8 support in MySQL and MariaDB requires the Barracuda file format. Please convert the tables to the Barracuda file format. See the documentation Administration via command line for details of a tool for converting InnoDB tables to Barracuda.


For full support of UTF-8 both MySQL and MariaDB require you to change your MySQL setting ‘innodb_large_prefix’ to ‘ON’. See the documentation for further details.

If I run the command line script mysql_compressed_rows.php --list is meant to show the files to be converted, no files show and the --fix has nothing to fix.

I looked at it with phpmyadmin and the UTF-8 colation seems already selected.

Any clues


try to follow link in last point of server requirements here on this link: - when you follow it - it have step by step how to convert your db properly. You aint mentioned what distro you running on. if no luck I would suggest you to contact developer of moodle.