Modules are disappearing

OS type and version Linux Ubuntu 22
Webmin version 2.101
Virtualmin version 7.8.2
Related packages SUGGESTED

Modules are just being uninstalled without any notice…

it first started with nginx server option menu, it disappeared.
Then it was a mail wrapper.
Today it was awstats (/usr/lib/cgi-bin/ was not found on your system.)
Now its let’s encrypt…

Is that because i manually set proxy in nginx? now im being punished?

When i want to create a new virtual server, nginx server is no longer there too

although i installed all my previous virtual server with it (and they are still active with nginx…)

Nothing to do with the latest version.
BTW your Virtualmin version is way out of date! 2.8.2 I’m not even sure there was such a version so perhaps a typo ? (you can copy to clipboard without typos the system info by clicking on the clipboard icon on the dashboard)

OS type and version Ubuntu Linux 22.04.3
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.8.2
Theme version 21.04
Package updates All installed packages are up to date

create VS on my nginx system gives

Sorry indeed i 7.8.2 not 2.8.2

Is this list missing nginx or is it normal?

Also, was there a “let’s encrypt” tab here or did i dream it?

Did you uninstall the packages that provide those features? (e.g. webmin-virtualmin-nginx and webmin-virtualmin-nginx-ssl)

Nothing about the Virtualmin update would have altered any of this.

1 Like

#No not normal.
You are missing Nginx website and Nginx SSSL website
I would Recheck Configuration and see what shows up.

@Joe remember that other topic today about Apache having been removed from Virtualmin and the potential confusion well here is one that was missed! Virtualmin -> System Settings -> Features and Plugins

I did not removed them, at least not intentionnally or manually.
How can i check if they are still here, and/or reinstall them?

Not a dream it should be still there

1 Like

Don’t hijack the thread with unrelated stuff. And, that won’t change, as Apache support is built into Virtualmin core; it can’t be removed without significant re-architecting. nginx is a module that’s installed in a separate package. (And, again, I think it’s not too much to ask of a server administrator that they know which web server they are using. That’s a low bar.)

thank you it worked by apt installing the two packages you mentionned. Lets encrypt also came back by installing them!
Is there a list of webmin-virtualmin packages i could check to see if i miss other packages?

So…maybe figure out what you did to cause them to be uninstalled? That’s scary stuff. If you’re randomly removing packages, it’s very easy to end up with a catastrophically broken system.

I just researched my logs
Here is what i found

Start-Date: 2023-08-11  11:31:14
Commandline: apt-get -y install code libldap-2.5-0 libldap-common microsoft-edge-stable opera-stable usermin virtualmin-config webmin
Install: libencode-detect-perl:amd64 (1.01-5build5, automatic), lynx:amd64 (2.9.0dev.10-1, automatic), lynx-common:amd64 (2.9.0dev.10-1, automatic)
Upgrade: libldap-common:amd64 (2.5.15+dfsg-0ubuntu0.22.04.1, 2.5.16+dfsg-0ubuntu0.22.04.1), virtualmin-config:amd64 (7.0.12, 7.0.13), opera-stable:amd64 (101.0.4843.33, 101.0.4843.43), webmin:amd64 (2.021, 2.101), libldap-2.5-0:amd64 (2.5.15+dfsg-0ubuntu0.22.04.1, 2.5.16+dfsg-0ubuntu0.22.04.1), usermin:amd64 (1.861, 2.001), code:amd64 (1.81.0-1690980880, 1.81.1-1691620686), microsoft-edge-stable:amd64 (115.0.1901.200-1, 115.0.1901.203-1)
End-Date: 2023-08-11  11:32:13


Start-Date: 2023-08-14 11:36:46
Commandline: apt autoremove
Requested-By: fauxprophet (1007)
Remove: clamav-daemon:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), postgrey:amd64 (1.36-5.2), libnet-dns-perl:amd64 (1.33-1), certbot:amd64 (1.21.0-1build1), libnet-cidr-perl:amd64 (0.21-1), libn
etaddr-ip-perl:amd64 (4.079+dfsg-1build7), python3-pyasn1:amd64 (0.4.8-1), python3-s3transfer:amd64 (0.5.0-1), libonig5:amd64 (, mariadb-server:amd64 (1:10.6.12-0ubuntu0.22.
04.1), libtype-tiny-xs-perl:amd64 (0.022-1build2), libfcgi-perl:amd64 (0.82+ds-1build1), libhiredis0.14:amd64 (0.14.1-2), procmail-wrapper:amd64 (1.1-3), libmail-spf-perl:amd64 (2.9.0-5), p
ython3-zope.hookable:amd64 (5.1.0-1build1), libexporter-tiny-perl:amd64 (1.002002-1), libdbd-mysql-perl:amd64 (4.050-5), clamav:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), proftpd-mod-crypto:amd
64 (1.3.7c+dfsg-1build1), libperl4-corelibs-perl:amd64 (0.004-2), galera-4:amd64 (26.4.9-1build1), clamav-base:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), libparse-syslog-perl:amd64 (1.10-3.1),
libmemcachedutil2:amd64 (1.0.18-4.2ubuntu4), libclamav9:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), milter-greylist:amd64 (4.6.4-1), fonts-lato:amd64 (2.0-2.1), php-common:amd64 (2:92ubuntu1), p
hp8.1-opcache:amd64 (8.1.2-1ubuntu2.13), php8.1-mysql:amd64 (8.1.2-1ubuntu2.13), fail2ban:amd64 (0.11.2-6), libcrypt-openssl-bignum-perl:amd64 (0.09-1build7), liblockfile-bin:amd64 (1.17-1b
uild2), python3-jmespath:amd64 (0.10.0-1), libdigest-bubblebabble-perl:amd64 (0.02-2.1), libmspack0:amd64 (0.10.1-2build2), libio-multiplex-perl:amd64 (1.16-1.1), proftpd-core:amd64 (1.3.7c
+dfsg-1build1), python3-acme:amd64 (1.21.0-1ubuntu0.1), python3-zope.component:amd64 (4.3.0-3), ruby-net-telnet:amd64 (0.1.1-2), libmail-authenticationresults-perl:amd64 (2.20210915-1), pro
ftpd-basic:amd64 (1.3.7c+dfsg-1build1), clamav-testfiles:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), sa-compile:amd64 (3.4.6-1ubuntu0.22.04.1), clamav-freshclam:amd64 (0.103.8+dfsg-0ubuntu0.22.0
4.1), libcrypt-openssl-rsa-perl:amd64 (0.32-1ubuntu2), rubygems-integration:amd64 (1.18), proftpd-mod-wrap:amd64 (1.3.7c+dfsg-1build1), mariadb-server-core-10.6:amd64 (1:10.6.12-0ubuntu0.22
.04.1), python3-parsedatetime:amd64 (2.6-2), libruby3.0:amd64 (3.0.2-7ubuntu2.4), libnet-server-perl:amd64 (2.009-2), libmoo-perl:amd64 (2.005004-3), libhtml-template-perl:amd64 (2.97-1.1),
docutils-common:amd64 (0.17.1+dfsg-2), rake:amd64 (13.0.6-2), re2c:amd64 (3.0-1), lockfile-progs:amd64 (0.1.19build1), php8.1-mbstring:amd64 (8.1.2-1ubuntu2.13), libtype-tiny-perl:amd64 (1
.012004-1), libcrypt-openssl-random-perl:amd64 (0.15-2build4), libnet-ip-perl:amd64 (1.26-2), libnet-dns-sec-perl:amd64 (1.19-1build2), libnet-rblclient-perl:amd64 (0.5-3), python3-docutils
:amd64 (0.17.1+dfsg-2), libdaxctl1:amd64 (72.1-1), libimport-into-perl:amd64 (1.002005-1), php-mbstring:amd64 (2:8.1+92ubuntu1), libspf2-2:amd64 (1.2.10-7.1ubuntu1), libterm-readkey-perl:am
d64 (2.38-1build4), php-cgi:amd64 (2:8.1+92ubuntu1), php-cli:amd64 (2:8.1+92ubuntu1), php8.1-common:amd64 (8.1.2-1ubuntu2.13), php-fpm:amd64 (2:8.1+92ubuntu1), sendmail-cf:amd64 (8.15.2-22u
buntu3), ruby:amd64 (1:3.0~exp1), libgeoip1:amd64 (1.6.12-8), php8.1-readline:amd64 (8.1.2-1ubuntu2.13), python3-pyinotify:amd64 (0.9.6-1.3), ruby3.0-doc:amd64 (3.0.2-7ubuntu2.4), libnet-xw
hois-perl:amd64 (0.90-4.1), python3-certbot:amd64 (1.21.0-1build1), python3-roman:amd64 (3.3-1), p7zip:amd64 (16.02+dfsg-8), libtfm1:amd64 (0.13-4build2), geoip-database:amd64 (20191224-3),
php-mysql:amd64 (2:8.1+92ubuntu1), jailkit:amd64 (2.23-1), mariadb-client-10.6:amd64 (1:10.6.12-0ubuntu0.22.04.1), libcgi-fast-perl:amd64 (1:2.15-1), python3-zope.interface:amd64 (5.4.0-1b
uild1), sendmail-base:amd64 (8.15.2-22ubuntu3), python3-icu:amd64 (2.8.1-0ubuntu2), awscli:amd64 (1.22.34-1), libconfig-inifiles-perl:amd64 (3.000003-1), mariadb-common:amd64 (1:10.6.12-0ub
untu0.22.04.1), python3-botocore:amd64 (1.23.34+repack-1), php-xml:amd64 (2:8.1+92ubuntu1), libauthen-oath-perl:amd64 (2.0.1-1), netfilter-persistent:amd64 (1.0.16), python3-josepy:amd64 (1
.10.0-1), clamav-docs:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), libberkeleydb-perl:amd64 (0.64-1build3), php-pear:amd64 (1:1.10.12+submodules+notgz+20210212-1ubuntu3), python3-rsa:amd64 (4.8-1
), webmin-virtualmin-nginx-ssl:amd64 (1.19), ruby3.0:amd64 (3.0.2-7ubuntu2.4), whois:amd64 (5.5.13), libndctl6:amd64 (72.1-1), clamdscan:amd64 (0.103.8+dfsg-0ubuntu0.22.04.1), python3-confi
gargparse:amd64 (1.5.3-1), libmail-dkim-perl:amd64 (1.20200907-1), libmariadb3:amd64 (1:10.6.12-0ubuntu0.22.04.1), awstats:amd64 (7.8-2ubuntu0.22.04.1), python3-zope.event:amd64 (4.4-3), we
bmin-virtualmin-nginx:amd64 (2.30), mariadb-client:amd64 (1:10.6.12-0ubuntu0.22.04.1), m4:amd64 (1.4.18-5ubuntu2), ri:amd64 (1:3.0~exp1), mariadb-server-10.6:amd64 (1:10.6.12-0ubuntu0.22.04
.1), php8.1-cgi:amd64 (8.1.2-1ubuntu2.13), ruby-rubygems:amd64 (3.3.5-2), php8.1-cli:amd64 (8.1.2-1ubuntu2.13), php8.1-fpm:amd64 (8.1.2-1ubuntu2.13), python3-configobj:amd64 (5.0.6-5), sens
ible-mda:amd64 (8.15.2-22ubuntu3), libcgi-pm-perl:amd64 (4.54-1), liblockfile1:amd64 (1.17-1build2), libpmem1:amd64 (1.11.1-3build1), proftpd-doc:amd64 (1.3.7c+dfsg-1build1), mariadb-client
-core-10.6:amd64 (1:10.6.12-0ubuntu0.22.04.1), quota:amd64 (4.06-1build2), libxml-simple-perl:amd64 (2.25-1), etckeeper:amd64 (1.18.16-1), php8.1-xml:amd64 (8.1.2-1ubuntu2.13), ruby-xmlrpc:
amd64 (0.3.2-1ubuntu0.1), ruby-webrick:amd64 (1.7.0-3), spamc:amd64 (3.4.6-1ubuntu0.22.04.1), spamassassin:amd64 (3.4.6-1ubuntu0.22.04.1)
End-Date: 2023-08-14 11:37:30

It seems then, that an autoremove had place many of virtualmin packages to be remove. I dont know if its related to the update. I dont see any instruction to delete specific virtualmin packages in the logs.

So, you removed the packages. Mystery solved. So, maybe don’t do that in the future to avoid this problem.

When running autoremove, you really need to read what it’s removing before letting it proceed! In this case, you removed pretty big chunks of the Virtualmin dependencies.

Virtualmin is installed by installing a couple of metapackages that depend on a bunch of other packages (GitHub - virtualmin/virtualmin-lamp-stack-ubu: Ubuntu metapackage that depends on the LAMP stack for Virtualmin). If you remove that package, for example by installing a package that conflicts with Virtualmin dependencies, you are making all the packages that were installed to satisfy those dependencies eligible for autoremove. I, personally, would never run autoremove on a production server, without first looking at what is eligible for autoremoval and making sure I understand the implications of letting that happen. If it includes packages I need, I will mark them for install (which makes them no longer eligible for autoremoval).

This is how many stacks of packages are installed on Debian or Ubuntu, Virtualmin is not unique in doing this, and it’s very easy to do destructive stuff with autoremove in the case of those metapackages, as well. So, be careful with autoremove!

Note you would have had virtualmin-lemp-stack or virtualmin-lemp-stack-minimal rather than the lamp version, since you’re using nginx. That package is generated from the lamp packages, rather than being separately maintained in that repo.

1 Like