Module mysql does not exist

Hi all,

I’m new to configuring webmin/virtualmin.

I had some issues with logging in to mysql as root and while re-configuring webmin I accidentally uninstalled the whole mysql module/plugin from webmin/virtualmin panel.

Question: how do I re-install it again? I have tried re-installing virtualmin/webmin and I know that the Mysql server is installed on the server but i still get the following page when trying to login back into the server:

https://www.byswiff.se:10000/

Thanks for any pointers, this experience will teach me to really adhere to “if it’s not broken, don’t fix it” :slight_smile:

Are you sure you uninstalled the module? I would think it would be pretty hard to do accidentally. :wink:

You might have disabled it (very easily) in Virtualmin in the Features and Plugins page (just check the box to bring it back).

But, if you did actually uninstall it, you can reinstall it in the Webmin->Webmin->Webmin Configuration->Webmin Modules page. Select "Standard module from webmin.com" and choose MySQL Database Server.

yep, I know pretty hard to uninstall it accidentally. I tried so many settings and really made a mess of it and in the frustrtion, I deleted the module. Now I can’t access the installation to fix it. How do I access the site seeing as it complains about the needed module as soon as i enter here: https://www.byswiff.se:10000/. is there a “back door”. I’ve tried going in through here: /webminhttps://www.byswiff.se:10000/standard_chooser.cgi?mod=servers. turned referers_none=0 momentarily to gain access as suggested by the script but am stuck there.

Cheers for the prompt reply,

/Johan

You should be given the option to edit features. Turn off MySQL and it should let you in.

nice one! thanks for the superb support! you’ve heard this million of times before but i’ll say it again: you guys really rock!

/Johan

Can I quote you on that? :wink:

yes you can! :slight_smile:

Awesome. I’ve linked the quote to swiff.se. Holler if you prefer your linkage to go somewhere else. (I just noticed a few days ago that we’re now PR7…so our links can’t a bad thing.)

hehe, thanks. please change the link to www.swiff.se :slight_smile:

Done.

Hi Joe,

I just got a weird error while trying to access FTP. The system does not seem to let me access any files under the “public_html” folder for my users. Also tried to access the wonderful “File Manager” now I get “ssl handshake exception”. Please help! I’ve update webmin to newer version but still getting the same errror.

I’m confused. What does this have to do with the MySQL module?

I’m having a hard time figuring out what you’re asking or what problem you’re having. I don’t see any error messages or any actual description of the symptoms of your problem. “weird error” is not a useful problem description.

Sorry, I posted to wrong thread. This does not relate to MySql module.
It’related to this post: http://www.virtualmin.com/index.php?option=com_flyspray&Itemid=82&do=details&task_id=3634

I’ve turned off ssl encryption as suggested, as I don’t have real ssl key, was just using the self-signed one as per server installation.

The other error, I’m getting, what called the “weird error” is that when using FTP, my users’ get “permission denied” when trying to write to a directory they have access to. Can’t understand how this have changed all of a sudden. Trying to pinpoint it, only thing I can come up with is that perhaps they’ve tried to access their folder with the wrong credentials too many times - basically been locked out? I’m trying to find a “reset” feature in the settings panel.

Thanks for your prompt reply and sorry for the confusion and posting to the wrong thread.

/Johan

So, yeah, start new threads when you have new questions. My brain works a bit slow, but I usually manage to struggle through each day if things are nicely organized. :wink:

We’ll need to see some logs on the FTP issue.